summaryrefslogtreecommitdiff
path: root/render-test/android/app/build.gradle
diff options
context:
space:
mode:
authorzmiao <miao.zhao@mapbox.com>2019-10-22 16:32:21 +0300
committerGitHub <noreply@github.com>2019-10-22 16:32:21 +0300
commit068befa9df1c55904ec7e26bee062e5e33aecbce (patch)
treeb805b79750e0986fb2821fed1c0bd1c5d8cc5b18 /render-test/android/app/build.gradle
parent2cdc09dbb13964ffd2af1e8776a56c70f80e0360 (diff)
downloadqtlocation-mapboxgl-068befa9df1c55904ec7e26bee062e5e33aecbce.tar.gz
[test-runner] Run render test runner as a NativeActivity app on android device (#15827)
* [test-runner]Add android render-test-runner NativeActivity app * [test-runner] Fix cmake for CI build failure * [test-runner] Update folder location, change app configureation * [test-runner] Add running instruction
Diffstat (limited to 'render-test/android/app/build.gradle')
-rw-r--r--render-test/android/app/build.gradle29
1 files changed, 29 insertions, 0 deletions
diff --git a/render-test/android/app/build.gradle b/render-test/android/app/build.gradle
new file mode 100644
index 0000000000..60609e3ba2
--- /dev/null
+++ b/render-test/android/app/build.gradle
@@ -0,0 +1,29 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 28
+
+ defaultConfig {
+ applicationId = 'com.mapbox.mapboxsdk.maps.render_test_runner'
+ minSdkVersion 14
+ targetSdkVersion 28
+ externalNativeBuild {
+ cmake {
+ arguments '-DANDROID_CCACHE=ccache'
+ arguments '-DANDROID_STL=c++_static'
+ targets 'mbgl-render-test-runner'
+ }
+ }
+ }
+ externalNativeBuild {
+ cmake {
+ version '3.10.2'
+ path '../../../next/CMakeLists.txt'
+ }
+ }
+}
+
+dependencies {
+ implementation 'androidx.appcompat:appcompat:1.0.2'
+ implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
+}