summaryrefslogtreecommitdiff
path: root/platform/glfw/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Shalamov <alexander.shalamov@mapbox.com>2020-02-26 14:25:48 +0200
committerAlexander Shalamov <alexander.shalamov@mapbox.com>2020-03-05 17:43:37 +0200
commitca4356fd0f1bb3dc78052a0a514f2ddb82f8376b (patch)
treef2bcb7b47ed73154aa3764894c3c17dc05966f4b /platform/glfw/CMakeLists.txt
parent9a0bc1b58b775209417582867c713b2015353a78 (diff)
downloadqtlocation-mapboxgl-ca4356fd0f1bb3dc78052a0a514f2ddb82f8376b.tar.gz
[glfw] Add snapshotter to glfw test app
Diffstat (limited to 'platform/glfw/CMakeLists.txt')
-rw-r--r--platform/glfw/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/platform/glfw/CMakeLists.txt b/platform/glfw/CMakeLists.txt
index 0b26cc83b1..93df7d58a4 100644
--- a/platform/glfw/CMakeLists.txt
+++ b/platform/glfw/CMakeLists.txt
@@ -11,11 +11,15 @@ add_executable(
${PROJECT_SOURCE_DIR}/platform/glfw/glfw_renderer_frontend.cpp
${PROJECT_SOURCE_DIR}/platform/glfw/settings_json.cpp
${PROJECT_SOURCE_DIR}/platform/glfw/test_writer.cpp
+ ${PROJECT_SOURCE_DIR}/platform/default/src/mbgl/map/map_snapshotter.cpp
)
target_include_directories(
mbgl-glfw
- PRIVATE ${GLFW_INCLUDE_DIRS}
+ PRIVATE
+ ${GLFW_INCLUDE_DIRS}
+ # For /platform/default/src/mbgl/map/map_snapshotter.hpp
+ PRIVATE ${PROJECT_SOURCE_DIR}/src
)
include(${PROJECT_SOURCE_DIR}/vendor/cheap-ruler-cpp.cmake)