summaryrefslogtreecommitdiff
path: root/next/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Alanen <juha.alanen@mapbox.com>2020-01-23 14:24:09 +0200
committerJuha Alanen <juha.alanen@mapbox.com>2020-02-06 13:38:10 +0200
commitad4002c17b3e53f48b4e91e57cad94b6c962bac4 (patch)
treefc27534d2ddf1bbca0e6751b705e7e28e7629afa /next/test/CMakeLists.txt
parentfe05c01c5efe9e68632c878d048adaa698135b5a (diff)
downloadqtlocation-mapboxgl-ad4002c17b3e53f48b4e91e57cad94b6c962bac4.tar.gz
[test] Enable HTTP server on Androidupstream/jmalanen-android-curl
Diffstat (limited to 'next/test/CMakeLists.txt')
-rw-r--r--next/test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/next/test/CMakeLists.txt b/next/test/CMakeLists.txt
index ce980f78d1..a9814aa033 100644
--- a/next/test/CMakeLists.txt
+++ b/next/test/CMakeLists.txt
@@ -117,7 +117,7 @@ if(MBGL_WITH_OPENGL)
)
endif()
-if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL Android)
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL Android AND ANDROID_NATIVE_API_LEVEL VERSION_LESS 24)
message("Target platform does not support HTTP tests or dependencies not found.")
set(MBGL_TEST_HAS_TEST_SERVER 0)