summaryrefslogtreecommitdiff
path: root/next/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Alanen <juha.alanen@mapbox.com>2019-12-19 15:55:39 +0200
committerJuha Alanen <juha.alanen@mapbox.com>2020-01-10 17:19:30 +0200
commit0b3942572e5fc7be575ff15c82a9e31d508609f7 (patch)
treed3ef09c2117a03bee3b85f5e62a5b9a10c285a9c /next/test/CMakeLists.txt
parentf24e4ca0689c023cf5499c4a78ba7a20b3e9a4c0 (diff)
downloadqtlocation-mapboxgl-0b3942572e5fc7be575ff15c82a9e31d508609f7.tar.gz
[test] Run unit tests as NativeActivity application on Android
Diffstat (limited to 'next/test/CMakeLists.txt')
-rw-r--r--next/test/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/next/test/CMakeLists.txt b/next/test/CMakeLists.txt
index 761064f5b2..06d8045d0a 100644
--- a/next/test/CMakeLists.txt
+++ b/next/test/CMakeLists.txt
@@ -1,5 +1,5 @@
add_library(
- mbgl-test SHARED EXCLUDE_FROM_ALL
+ mbgl-test STATIC EXCLUDE_FROM_ALL
${MBGL_ROOT}/test/actor/actor.test.cpp
${MBGL_ROOT}/test/actor/actor_ref.test.cpp
${MBGL_ROOT}/test/algorithm/update_renderables.test.cpp
@@ -157,8 +157,7 @@ target_link_libraries(
Mapbox::Base::Extras::args
Mapbox::Base::pixelmatch-cpp
mbgl-compiler-options
- mbgl-core
- $<$<PLATFORM_ID:Android>:mbgl-core-android>
+ PUBLIC mbgl-core
)
target_link_libraries(