summaryrefslogtreecommitdiff
path: root/deps/gyp/setup.py
diff options
context:
space:
mode:
authorDane Springmeyer <dane@mapbox.com>2014-05-27 19:03:55 -0700
committerDane Springmeyer <dane@mapbox.com>2014-05-27 19:03:55 -0700
commit15aa4ee90d89a710e5e3a6c044ba6169474aa1fb (patch)
tree815f5d3e1b68a3079909fc501cfd93739f826699 /deps/gyp/setup.py
parenta1835b3fc27b8fecaa947eb578c60450e3063635 (diff)
downloadqtlocation-mapboxgl-15aa4ee90d89a710e5e3a6c044ba6169474aa1fb.tar.gz
Add missing gyp files
Diffstat (limited to 'deps/gyp/setup.py')
-rwxr-xr-xdeps/gyp/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/deps/gyp/setup.py b/deps/gyp/setup.py
new file mode 100755
index 0000000000..75a42558d8
--- /dev/null
+++ b/deps/gyp/setup.py
@@ -0,0 +1,19 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2009 Google Inc. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+from setuptools import setup
+
+setup(
+ name='gyp',
+ version='0.1',
+ description='Generate Your Projects',
+ author='Chromium Authors',
+ author_email='chromium-dev@googlegroups.com',
+ url='http://code.google.com/p/gyp',
+ package_dir = {'': 'pylib'},
+ packages=['gyp', 'gyp.generator'],
+ entry_points = {'console_scripts': ['gyp=gyp:script_main'] }
+)