summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2016-12-22 16:13:57 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-01-09 19:05:28 -0800
commitf1b56a2c07b72ea84ec176571eac0bdb392e4a08 (patch)
tree1f0e6b0a8868b93dfab1a448f4b965ec3ed17624 /CMakeLists.txt
parent9f9e820540af4e7e988fe70b838a82842d44da93 (diff)
downloadqtlocation-mapboxgl-f1b56a2c07b72ea84ec176571eac0bdb392e4a08.tar.gz
[build] Symlink mapbox-gl-js/node_modules so that it shares a cache
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1fcbb6c360..aa25cd6def 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,11 @@ if(NOT EXISTS "mapbox-gl-js/package.json")
execute_process(
COMMAND git submodule update --init mapbox-gl-js
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+ # Symlink mapbox-gl-js/node_modules so that the modules that are
+ # about to be installed get cached between CI runs.
+ execute_process(
+ COMMAND ln -s ../node_modules node_modules
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)
execute_process(
COMMAND npm install
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)