summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2017-07-11 11:33:51 +0200
committerKonstantin Käfer <mail@kkaefer.com>2017-07-11 16:23:19 +0200
commite364f24570f863044b9c464c2eb8c0fd75c5a80b (patch)
treefd1e51eb653f2c3cc8d7294bbd9d4b9a1c1d0db7 /CMakeLists.txt
parentd03fd0dce2efc101021b4cf351945680afaa4349 (diff)
downloadqtlocation-mapboxgl-e364f24570f863044b9c464c2eb8c0fd75c5a80b.tar.gz
[build] Don't fail hard for unknown warning groups
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 189f033b79..694147fc8f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,7 +77,10 @@ if(APPLE)
endif()
set(CMAKE_CXX_FLAGS_RELEASE "-Os -DNDEBUG")
-if(CMAKE_COMPILER_IS_GNUCXX)
+
+if(CMAKE_CXX_COMPILER_ID MATCHES ".*Clang")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unknown-warning-option")
+elseif(CMAKE_COMPILER_IS_GNUCXX)
# https://svn.boost.org/trac/boost/ticket/9240
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fext-numeric-literals")
endif()