summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2014-01-16 13:53:10 +0100
committerKonstantin Käfer <mail@kkaefer.com>2014-01-16 13:53:10 +0100
commitc01719bc04c759d66be32d534d03057366c7f1b1 (patch)
treed361458f6e1a8b4eda86a509f244dd52f243119b /CMakeLists.txt
parent8fd762b5f3c437beee60c7124e30f6994a6fcb3a (diff)
downloadqtlocation-mapboxgl-c01719bc04c759d66be32d534d03057366c7f1b1.tar.gz
make bundle on mac os x and persist settings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa5ddfdfab..2919943c69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,16 @@
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
project(llmr)
+
+set(VERSION_MAJOR "0")
+set(VERSION_MINOR "0")
+set(VERSION_PATCH "1")
+
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++11")
add_subdirectory(src)
-add_subdirectory(macosx)
+
+
+if(APPLE)
+ add_subdirectory(macosx)
+endif(APPLE)