summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno de Oliveira Abinader <bruno@mapbox.com>2016-11-07 10:54:38 +0200
committerBruno de Oliveira Abinader <bruno@mapbox.com>2016-11-08 18:02:38 +0200
commit8e99ae44dd5bf72bc8bd844251e9d670095804ac (patch)
tree38ddbf84fea7c9385de25f981d298fec9a99166a /CMakeLists.txt
parentd0ac12309b470eb59690ece3f15773df73a127e1 (diff)
downloadqtlocation-mapboxgl-8e99ae44dd5bf72bc8bd844251e9d670095804ac.tar.gz
[build] Use mesa-13.0.0-glx in CI builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c80e999a3f..6c009b910a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ include(.mason/mason.cmake)
option(WITH_CXX11ABI "Use cxx11abi mason packages" OFF)
option(WITH_COVERAGE "Enable coverage reports" OFF)
option(WITH_OSMESA "Use OSMesa headless backend" OFF)
+option(IS_CI_BUILD "Continuous integration build" OFF)
if(WITH_CXX11ABI)
set(MASON_CXXABI_SUFFIX -cxx11abi)
@@ -22,6 +23,12 @@ endif()
if(WITH_OSMESA)
add_compile_options(-D__OSMESA__)
+else()
+ set(MASON_MESA_SUFFIX -glx)
+endif()
+
+if(IS_CI_BUILD)
+ add_compile_options(-DCI_BUILD=1)
endif()
mason_use(geometry VERSION 0.8.0 HEADER_ONLY)