summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2017-01-17 13:14:46 -0800
committerKonstantin Käfer <mail@kkaefer.com>2017-01-18 11:53:16 +0100
commit89193f7ab03cecaa88c4413b3b54f837c2effc56 (patch)
tree2ee10c70c1feb7aea5a1f93cf2b81d24fa591691 /CMakeLists.txt
parent531a1c3070a098b5b31082c0500f0a3ce6a500bb (diff)
downloadqtlocation-mapboxgl-89193f7ab03cecaa88c4413b3b54f837c2effc56.tar.gz
[build] Avoid creating a recursively symlinked node_modules
With the previous command, the second time it would run generated a node_modules symlink inside the top-level node_modules directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa25cd6def..59d84d33fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,7 +17,7 @@ if(NOT EXISTS "mapbox-gl-js/package.json")
# Symlink mapbox-gl-js/node_modules so that the modules that are
# about to be installed get cached between CI runs.
execute_process(
- COMMAND ln -s ../node_modules node_modules
+ COMMAND ln -sF ../node_modules .
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)
execute_process(
COMMAND npm install