summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJason Wray <friedbunny@users.noreply.github.com>2017-07-18 12:36:22 -0400
committerGitHub <noreply@github.com>2017-07-18 12:36:22 -0400
commit05df451f3c370e6ba8a02d8b0268d88c23db269b (patch)
tree7f046e3b79be43e355ce4dcbca612cf214f1d51b /CMakeLists.txt
parent964287e5a4f93284b5b1e22da69ffc7c53e3e41f (diff)
downloadqtlocation-mapboxgl-05df451f3c370e6ba8a02d8b0268d88c23db269b.tar.gz
[build] Add ccache install reminder and docs (#9520)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6758cdacb..8ce43f998a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -119,6 +119,8 @@ if(CCACHE_PROGRAM)
# Clang also thinks that ccache isn't interactive, so we explicitly need to enable color.
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Qunused-arguments -fcolor-diagnostics")
endif()
+else()
+ message(STATUS "Can't find ccache — consider installing ccache to improve recompilation performance")
endif()
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/platform/${MBGL_PLATFORM}/config.cmake)