summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Firebaugh <john.firebaugh@gmail.com>2017-01-09 15:32:03 -0800
committerJohn Firebaugh <john.firebaugh@gmail.com>2017-01-09 19:05:28 -0800
commit9f9e820540af4e7e988fe70b838a82842d44da93 (patch)
treef0f186a520eeae9163a9106c1e5ac5eda50580b3 /CMakeLists.txt
parentf6f82d15abb534f618cec090c4592f87f0511523 (diff)
downloadqtlocation-mapboxgl-9f9e820540af4e7e988fe70b838a82842d44da93.tar.gz
[build] Use test-suite integration tests from mapbox-gl-js
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41df0f2a12..1fcbb6c360 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,9 @@ if(NOT EXISTS "mapbox-gl-js/package.json")
execute_process(
COMMAND git submodule update --init mapbox-gl-js
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+ execute_process(
+ COMMAND npm install
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/mapbox-gl-js)
endif()
include(.mason/mason.cmake)