summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Marcos P. Santos <tmpsantos@gmail.com>2018-01-03 18:27:25 +0200
committerThiago Marcos P. Santos <tmpsantos@gmail.com>2018-01-08 22:58:20 +0200
commitf391271532895c8a36cf20b6ccd20c49ee50176b (patch)
treedcebdbe0f613ec3fce40b14b74e8f48b0b4967b6 /CMakeLists.txt
parent035418336e84d1afbeed989cd3a112e06d0b4590 (diff)
downloadqtlocation-mapboxgl-f391271532895c8a36cf20b6ccd20c49ee50176b.tar.gz
[windows][build] Make nodejs/npm optional
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf4eda5252..69bb5abe4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,14 +2,15 @@ cmake_minimum_required(VERSION 3.4)
project(mbgl LANGUAGES CXX C)
set(CMAKE_CXX_STANDARD 14)
-include(cmake/mbgl.cmake)
-include(cmake/mason.cmake)
-include(cmake/xcode.cmake)
-
option(WITH_CXX11ABI "Use cxx11abi mason packages" OFF)
option(WITH_COVERAGE "Enable coverage reports" OFF)
option(WITH_OSMESA "Use OSMesa headless backend" OFF)
option(WITH_EGL "Use EGL backend" OFF)
+option(WITH_NODEJS "Download test dependencies like NPM and Node.js" ON)
+
+include(cmake/mbgl.cmake)
+include(cmake/mason.cmake)
+include(cmake/xcode.cmake)
if(WITH_CXX11ABI)
set(MASON_CXXABI_SUFFIX -cxx11abi)