summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2018-05-24 11:25:12 +0200
committerKonstantin Käfer <mail@kkaefer.com>2018-05-24 21:50:29 +0200
commit2694c0df037265fd37c6b9dc709efd5fa3472b12 (patch)
tree40fdc111969ab54237db395cd140b0fc8e29c770 /CMakeLists.txt
parentb1f696155e2ff18e6d76c8f74eafadc7ee59cf71 (diff)
downloadqtlocation-mapboxgl-2694c0df037265fd37c6b9dc709efd5fa3472b12.tar.gz
[build] disable parts of the build that require node when WITH_NODEJS=OFF is set
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46aea73356..c2f7134de7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -166,7 +166,7 @@ if(COMMAND mbgl_platform_offline)
include(cmake/offline.cmake)
endif()
-if(COMMAND mbgl_platform_node)
+if(WITH_NODEJS AND COMMAND mbgl_platform_node)
include(cmake/node.cmake)
endif()