summaryrefslogtreecommitdiff
path: root/examples/widgets/painting/fontsampler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/painting/fontsampler/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/fontsampler/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/examples/widgets/painting/fontsampler/CMakeLists.txt b/examples/widgets/painting/fontsampler/CMakeLists.txt
index e60c0061b6..23f2bb4c29 100644
--- a/examples/widgets/painting/fontsampler/CMakeLists.txt
+++ b/examples/widgets/painting/fontsampler/CMakeLists.txt
@@ -4,9 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(fontsampler LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTOUIC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -18,6 +15,8 @@ find_package(Qt6
OPTIONAL_COMPONENTS PrintSupport
)
+qt_standard_project_setup()
+
qt_add_executable(fontsampler
main.cpp
mainwindow.cpp mainwindow.h