summaryrefslogtreecommitdiff
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-11-15 22:50:53 +0100
committerKai Köhne <kai.koehne@qt.io>2022-11-30 14:48:50 +0100
commitd221ea609fdd9f5dc99f520391beddc057373278 (patch)
tree5e0aa39ba1807b226f11c17b9b7607182ede055d /examples/widgets/tutorials/notepad/CMakeLists.txt
parentde7287be69b449b1da13148e62fbeef0406eb792 (diff)
downloadqtbase-d221ea609fdd9f5dc99f520391beddc057373278.tar.gz
Examples: Remove duplicated Qt6::PrintSupport link information
Some CMakeLists.txt files did link to Qt6::PrintSupport twice. Also unify formatting and order of the linker step. Change-Id: I4af935c5dc3de6c243aad8511b0803ceaa872589 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
index a334176b9a..b2a5fae402 100644
--- a/examples/widgets/tutorials/notepad/CMakeLists.txt
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -33,6 +33,10 @@ target_link_libraries(notepad PUBLIC
Qt6::Widgets
)
+if(TARGET Qt6::PrintSupport)
+ target_link_libraries(notepad PUBLIC Qt6::PrintSupport)
+endif()
+
# Resources:
set(notepad_resource_files
"images/bold.png"
@@ -62,12 +66,6 @@ qt_add_resources(notepad "notepad"
${notepad_resource_files}
)
-if(TARGET Qt6::PrintSupport)
- target_link_libraries(notepad PUBLIC
- Qt6::PrintSupport
- )
-endif()
-
install(TARGETS notepad
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"