summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2013-06-29 10:47:03 -0400
committerJason R. Coombs <jaraco@jaraco.com>2013-06-29 10:47:03 -0400
commit16e8b17aeee143d8c181c4621bd3440e460e8c3b (patch)
tree533adf8c6027c61c248d196ce600f0507b273e57 /setup.py
parentcaa55b1e3e3692c4ce604a8e680de2d62571ce0d (diff)
downloadpython-setuptools-bitbucket-16e8b17aeee143d8c181c4621bd3440e460e8c3b.tar.gz
Add comment to capture the purpose of the environment variable0.7.5
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fcf61e75..cb0ce012 100755
--- a/setup.py
+++ b/setup.py
@@ -55,6 +55,10 @@ from setuptools.command.test import test as _test
scripts = []
console_scripts = ["easy_install = setuptools.command.easy_install:main"]
+
+# Gentoo distributions manage the python-version-specific scripts themselves,
+# so they define an environment variable to suppress the creation of the
+# version-specific scripts.
if os.environ.get("SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT") in (None, "", "0") and \
os.environ.get("DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT") in (None, "", "0"):
console_scripts.append("easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3])