summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini12
1 files changed, 6 insertions, 6 deletions
diff --git a/tox.ini b/tox.ini
index 1c2eb66..bdd3774 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,20 +1,20 @@
[tox]
envlist =
- py27,py33,py34,py35,pypy,pypy3,coverage
+ py27,py34,py35,py36,pypy,pypy3,coverage
[testenv]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src []
deps =
- zope.testrunner
+ .[test]
[testenv:coverage]
usedevelop = true
basepython =
python2.7
commands =
- nosetests --with-xunit --with-xcoverage
+ coverage run -m zope.testrunner --test-path=src
+ coverage report --fail-under=82
deps =
- nose
+ {[testenv]deps}
coverage
- nosexcover