summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini13
1 files changed, 12 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 3f0cf63..56311c8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,10 +3,21 @@ envlist =
# pypy3 pending release of a fix for
# https://bitbucket.org/pypy/pypy/issue/1946
# py26,py27,py33,py34,pypy,pypy3
- py26,py27,py33,py34,pypy
+ py26,py27,py33,py34,pypy,coverage
[testenv]
commands =
python setup.py -q test -q
deps =
zope.testrunner
+
+[testenv:coverage]
+usedevelop = true
+basepython =
+ python2.7
+commands =
+ nosetests --with-xunit --with-xcoverage
+deps =
+ nose
+ coverage
+ nosexcover