summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-29 13:29:48 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-29 13:29:48 -0500
commit33903cd083a4d0af116e63d7ad70c160e89ec45b (patch)
tree545496f3be8a786da68e9aca2436ff44ed4a5431 /setup.py
parent0bc4d7831c8a1526db44c532eec5f18a1de78773 (diff)
downloadzope-tal-33903cd083a4d0af116e63d7ad70c160e89ec45b.tar.gz
Add support for Python 3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1eebf64..f2015dd 100644
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,8 @@ from setuptools import setup, find_packages
here = os.path.dirname(__file__)
def read(*rnames):
- return open(os.path.join(here, *rnames)).read()
+ with open(os.path.join(here, *rnames)) as f:
+ return f.read()
def alltests():
# use the zope.testrunner machinery to find all the
@@ -42,7 +43,7 @@ def alltests():
return TestSuite(suites)
setup(name='zope.tal',
- version='4.0.1dev',
+ version='4.1.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Template Application Language (TAL)',
@@ -63,6 +64,7 @@ setup(name='zope.tal',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',