summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2007-10-03 13:34:40 +0000
committerStephan Richter <stephan.richter@gmail.com>2007-10-03 13:34:40 +0000
commit1c08a0679bb15c73cddef5ac493c543958e8254a (patch)
treed7d8bdafc414106226a220cb92297ca30188eb43 /setup.py
parent476cd5e089febac0d0b42d7cc67536474b057168 (diff)
downloadzope-tal-1c08a0679bb15c73cddef5ac493c543958e8254a.tar.gz
Updated meta-data, getting ready for release.3.4.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 28 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index b09028f..b704df3 100644
--- a/setup.py
+++ b/setup.py
@@ -15,29 +15,46 @@
$Id$
"""
-
import os
-
from setuptools import setup, find_packages
+def read(*rnames):
+ return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+
setup(name='zope.tal',
- version = '3.4.0b2',
- url='http://svn.zope.org/zope.tal',
- license='ZPL 2.1',
- description='Zope 3 Template Application Languate (TAL)',
+ version = '3.4.0',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
-
+ description='Zope 3 Template Application Languate (TAL)',
+ long_description=(
+ read('README.txt')
+ + '\n\n' +
+ read('CHANGES.txt')
+ ),
+ keywords = "zope3 template xml tal",
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Zope Public License',
+ 'Programming Language :: Python',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Framework :: Zope3'],
+ url='http://cheeseshop.python.org/pypi/zope.tal',
+ license='ZPL 2.1',
packages=find_packages('src'),
package_dir = {'': 'src'},
-
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
+ extras_require = dict(
+ test=['zope.testing',
+ ]),
install_requires=['setuptools',
'zope.i18nmessageid',
- 'zope.i18n>=3.4.0b1',
+ 'zope.i18n',
'zope.interface',
],
include_package_data = True,
-
zip_safe = False,
)