summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-05-17 23:05:23 +0000
committerTres Seaver <tseaver@palladion.com>2012-05-17 23:05:23 +0000
commit08e1fb955b168a071c0423c9dc99eefd6c0b9065 (patch)
tree1c98e2dfe2d180c2c789325353d361f2a25cf7c8 /setup.py
parent718c3ea29cbfd8eec53a01762d2e3fac682eae3b (diff)
downloadzope-tal-08e1fb955b168a071c0423c9dc99eefd6c0b9065.tar.gz
Drop support for Python 2.4 and 2.5.
Replace deprecated 'zope.interface.implements' usage with equivalent 'zope.interface.implementer' decorator.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6efad70..e8de516 100644
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ def alltests():
return TestSuite(suites)
setup(name='zope.tal',
- version = '3.6.2dev',
+ version = '4.0.0dev',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Template Application Language (TAL)',
@@ -60,6 +60,9 @@ setup(name='zope.tal',
'Intended Audience :: Developers',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',