summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2015-02-23 10:57:09 -0500
committerTres Seaver <tseaver@palladion.com>2015-02-23 10:57:09 -0500
commit076392f9931bb37fff03f6a5aa5c6badc9743d68 (patch)
treea48703ee133bbcb98451aec0d9e5668edd2c1dce
parenta9dc91a5dafabe8d3a1d96168d8cb2fbef9f1df7 (diff)
downloadzope-tal-076392f9931bb37fff03f6a5aa5c6badc9743d68.tar.gz
Add coverage testing.
-rw-r--r--.gitignore3
-rw-r--r--setup.cfg9
-rw-r--r--tox.ini13
3 files changed, 24 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index d6e8ec4..ea2fef7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,6 @@ develop-eggs/
*.egg-info/
*.pyc
.tox
+.coverage
+coverage.xml
+nosetests.xml
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..c2de98e
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,9 @@
+[nosetests]
+nocapture=1
+cover-package=zope.tal
+cover-erase=1
+#cover-branches=1
+#cover-min-percentage=100
+with-doctest=0
+where=src
+
diff --git a/tox.ini b/tox.ini
index 3f0cf63..56311c8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,10 +3,21 @@ envlist =
# pypy3 pending release of a fix for
# https://bitbucket.org/pypy/pypy/issue/1946
# py26,py27,py33,py34,pypy,pypy3
- py26,py27,py33,py34,pypy
+ py26,py27,py33,py34,pypy,coverage
[testenv]
commands =
python setup.py -q test -q
deps =
zope.testrunner
+
+[testenv:coverage]
+usedevelop = true
+basepython =
+ python2.7
+commands =
+ nosetests --with-xunit --with-xcoverage
+deps =
+ nose
+ coverage
+ nosexcover