summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2013-09-26 23:39:22 +0300
committerMarius Gedminas <marius@gedmin.as>2013-09-26 23:39:22 +0300
commit772df8ea9155f9a9278c687302af1b1bf0b49dfe (patch)
tree245f5da01b616b4e92fd74ff1a316bd56e6993de
parenta7cd41e87cdb6c811208f4954e9e438d718f61ad (diff)
downloadzope-tal-772df8ea9155f9a9278c687302af1b1bf0b49dfe.tar.gz
Try to work around build failure on Travis
I can reproduce that failure locally, using tox. Only python 2.7 fails, Python 2.6 and 3.3 (and PyPy) are fine. The failure is a difference in filenames (relative versus absolute) in test_sa4.html. I've tried digging, but gave up. The failure appears if I run tox -e py27. It doesn't appear if I run tox -e py27 --develop. So let's tell Travis to use the latter, to at least catch new regressions.
-rw-r--r--.travis.yml14
1 files changed, 7 insertions, 7 deletions
diff --git a/.travis.yml b/.travis.yml
index 0adad65..3bbd29b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,12 +1,12 @@
language: python
-python:
- - 2.6
- - 2.7
- - 3.3
- - pypy
+env:
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py33
+ - TOXENV=pypy
install:
- - pip install . --use-mirrors
+ - pip install tox
script:
- - python setup.py test -q
+ - tox --develop
notifications:
email: false