summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2007-10-03 13:34:40 +0000
committerStephan Richter <stephan.richter@gmail.com>2007-10-03 13:34:40 +0000
commit1c08a0679bb15c73cddef5ac493c543958e8254a (patch)
treed7d8bdafc414106226a220cb92297ca30188eb43
parent476cd5e089febac0d0b42d7cc67536474b057168 (diff)
downloadzope-tal-1c08a0679bb15c73cddef5ac493c543958e8254a.tar.gz
Updated meta-data, getting ready for release.3.4.0
-rw-r--r--CHANGES.txt14
-rw-r--r--README.txt6
-rw-r--r--buildout.cfg6
-rw-r--r--setup.py39
4 files changed, 45 insertions, 20 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index fb56b8d..109f6c9 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,13 +1,17 @@
-zope.tal package changelog
-==========================
+=======
+CHANGES
+=======
+
+3.4.0 (2007-10-03)
+------------------
+
+- Updated package meta-data.
-After 3.4.0b1
--------------
3.4.0b1
-------
-- Updated dependency for zope.i18n that requires the correct version of
+- Updated dependency for ``zope.i18n`` that requires the correct version of
zope.security to avoid a hidden dependency issue in zope.security.
diff --git a/README.txt b/README.txt
index 0c39af0..0558e6b 100644
--- a/README.txt
+++ b/README.txt
@@ -1,9 +1,9 @@
-zope.tal Package Readme
-=======================
+Template Attribute Language (TAL)
+=================================
Overview
--------
--
+
The Zope3 Template Attribute Languate (TAL) specifies the custom namespace
and attributes which are used by the Zope Page Templates renderer to inject
dynamic markup into a page. It also includes the Macro Expansion for TAL
diff --git a/buildout.cfg b/buildout.cfg
index 923712e..99d192b 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -1,8 +1,12 @@
[buildout]
develop = .
parts = test
-find-links = http://download.zope.org/distribution/
+versions = versions
[test]
recipe = zc.recipe.testrunner
eggs = zope.tal
+
+[versions]
+zope.traversing = 3.4.0
+zope.app.publisher = 3.4.0
diff --git a/setup.py b/setup.py
index b09028f..b704df3 100644
--- a/setup.py
+++ b/setup.py
@@ -15,29 +15,46 @@
$Id$
"""
-
import os
-
from setuptools import setup, find_packages
+def read(*rnames):
+ return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+
setup(name='zope.tal',
- version = '3.4.0b2',
- url='http://svn.zope.org/zope.tal',
- license='ZPL 2.1',
- description='Zope 3 Template Application Languate (TAL)',
+ version = '3.4.0',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
-
+ description='Zope 3 Template Application Languate (TAL)',
+ long_description=(
+ read('README.txt')
+ + '\n\n' +
+ read('CHANGES.txt')
+ ),
+ keywords = "zope3 template xml tal",
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Zope Public License',
+ 'Programming Language :: Python',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Framework :: Zope3'],
+ url='http://cheeseshop.python.org/pypi/zope.tal',
+ license='ZPL 2.1',
packages=find_packages('src'),
package_dir = {'': 'src'},
-
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
+ extras_require = dict(
+ test=['zope.testing',
+ ]),
install_requires=['setuptools',
'zope.i18nmessageid',
- 'zope.i18n>=3.4.0b1',
+ 'zope.i18n',
'zope.interface',
],
include_package_data = True,
-
zip_safe = False,
)