summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2007-11-14 19:34:42 +0000
committerChris McDonough <chrism@plope.com>2007-11-14 19:34:42 +0000
commit1138edba17172249f329004126c6a3cc8a78b400 (patch)
tree9af8c8effc2df13d3910bd15be320dcd785f2e77
parenta9748346355817dbf1393b5dba4bde4113b3b88e (diff)
downloadzope-tal-1138edba17172249f329004126c6a3cc8a78b400.tar.gz
- Removed unnecessary 'dummyengine' dependency on zope.i18n to
simplify distribution. - Supprort ability to run tests using "setup.py test". - Stop pinning (no longer required) zope.traversing and zope.app.publisher versions in buildout.cfg.
-rw-r--r--CHANGES.txt12
-rw-r--r--buildout.cfg5
-rw-r--r--setup.py26
-rw-r--r--src/zope/tal/dummyengine.py2
4 files changed, 35 insertions, 10 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 109f6c9..53608d0 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,17 @@
CHANGES
=======
+Next Release
+------------
+
+- Removed unnecessary 'dummyengine' dependency on zope.i18n to
+ simplify distribution.
+
+- Supprort ability to run tests using "setup.py test".
+
+- Stop pinning (no longer required) zope.traversing and
+ zope.app.publisher versions in buildout.cfg.
+
3.4.0 (2007-10-03)
------------------
@@ -14,6 +25,5 @@ CHANGES
- Updated dependency for ``zope.i18n`` that requires the correct version of
zope.security to avoid a hidden dependency issue in zope.security.
-
Note: The code changes before 3.4.0b1 where not tracked as an individual
package and have been documented in the Zope 3 changelog.
diff --git a/buildout.cfg b/buildout.cfg
index 99d192b..e1e72b3 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -1,12 +1,7 @@
[buildout]
develop = .
parts = test
-versions = versions
[test]
recipe = zc.recipe.testrunner
eggs = zope.tal
-
-[versions]
-zope.traversing = 3.4.0
-zope.app.publisher = 3.4.0
diff --git a/setup.py b/setup.py
index b261f86..fa48bb1 100644
--- a/setup.py
+++ b/setup.py
@@ -16,10 +16,29 @@
$Id$
"""
import os
+import sys
from setuptools import setup, find_packages
+here = os.path.dirname(__file__)
+
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ return open(os.path.join(here, *rnames)).read()
+
+def alltests():
+ # use the zope.testing testrunner machinery to find all the
+ # test suites we've put under ourselves
+ from zope.testing.testrunner import get_options
+ from zope.testing.testrunner import find_suites
+ from zope.testing.testrunner import configure_logging
+ configure_logging()
+ from unittest import TestSuite
+ here = os.path.abspath(os.path.dirname(sys.argv[0]))
+ args = sys.argv[:]
+ src = os.path.join(here, 'src')
+ defaults = ['--test-path', src]
+ options = get_options(args, defaults)
+ suites = list(find_suites(options))
+ return TestSuite(suites)
setup(name='zope.tal',
version = '3.4.1dev',
@@ -50,9 +69,12 @@ setup(name='zope.tal',
extras_require = dict(
test=['zope.testing',
]),
+ test_suite="__main__.alltests", # to support "setup.py test"
+ tests_require = ['zope.i18nmessageid',
+ 'zope.interface',
+ 'zope.testing'],
install_requires=['setuptools',
'zope.i18nmessageid',
- 'zope.i18n',
'zope.interface',
],
include_package_data = True,
diff --git a/src/zope/tal/dummyengine.py b/src/zope/tal/dummyengine.py
index 2a35d84..26109ad 100644
--- a/src/zope/tal/dummyengine.py
+++ b/src/zope/tal/dummyengine.py
@@ -21,7 +21,6 @@ from zope.interface import implements
from zope.tal.taldefs import NAME_RE, TALExpressionError, ErrorInfo
from zope.tal.interfaces import ITALExpressionCompiler, ITALExpressionEngine
from zope.i18nmessageid import Message
-from zope.i18n.interfaces import ITranslationDomain
Default = object()
@@ -261,7 +260,6 @@ class Iterator(object):
class DummyTranslationDomain(object):
- implements(ITranslationDomain)
domain = ''