summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaiju Muthukadan <baiju.m.mail@gmail.com>2007-11-17 07:25:57 +0000
committerBaiju Muthukadan <baiju.m.mail@gmail.com>2007-11-17 07:25:57 +0000
commit075e937400e7cd41e309f5df96f125c947a00d0d (patch)
tree08423a4733c22de25b1fa34b6a2d8c2422ffe3b9
parent03e4d4c1679714bb7cd09d7e5f55b43f5b4dada7 (diff)
downloadzope-tal-075e937400e7cd41e309f5df96f125c947a00d0d.tar.gz
- `tests_require` only required to specify packages
not listed in `install_requires` To run tests, recommended way is to run ``setup.py develop`` follwed by ``setup.py test`` - s/cheeseshop/pypi -- long live PyPI ! - s/zope3-dev/zope-dev -- long live zope-dev !
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 0764a1c..86ebf26 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ def alltests():
setup(name='zope.tal',
version = '3.4.2dev',
author='Zope Corporation and Contributors',
- author_email='zope3-dev@zope.org',
+ author_email='zope-dev@zope.org',
description='Zope 3 Template Application Languate (TAL)',
long_description=(
read('README.txt')
@@ -61,7 +61,7 @@ setup(name='zope.tal',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
'Framework :: Zope3'],
- url='http://cheeseshop.python.org/pypi/zope.tal',
+ url='http://pypi.python.org/pypi/zope.tal',
license='ZPL 2.1',
packages=find_packages('src'),
package_dir = {'': 'src'},
@@ -70,9 +70,7 @@ setup(name='zope.tal',
test=['zope.testing',
]),
test_suite="__main__.alltests", # to support "setup.py test"
- tests_require = ['zope.i18nmessageid',
- 'zope.interface',
- 'zope.testing'],
+ tests_require = ['zope.testing'],
install_requires=['setuptools',
'zope.i18nmessageid',
'zope.interface',