summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini58
1 files changed, 58 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..eda704a
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,58 @@
+[tox]
+envlist =
+# Jython support pending 2.7 support, due 2012-07-15 or so. See:
+# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
+# py26,py27,pypy,jython,py32,py33,coverage,docs
+ py26,py27
+
+[testenv]
+deps =
+ RestrictedPython
+ zope.interface
+ zope.testing
+ zope.configuration
+ zope.component
+ zope.location
+ zope.proxy
+commands =
+ python setup.py test -q
+
+[testenv:coverage]
+basepython =
+ python2.6
+commands =
+# The installed version messes up nose's test discovery / coverage reporting
+# So, we uninstall that from the environment, and then install the editable
+# version, before running nosetests.
+ pip uninstall -y zope.security
+ python -c "import shutil; shutil.copyfile('src/zope/__init__.py', '{envdir}/lib/python2.6/site-packages/zope/__init__.py')"
+ pip install -e .
+ nosetests --with-xunit --with-xcoverage
+deps =
+ RestrictedPython
+ zope.interface
+ zope.testing
+ zope.configuration
+ zope.component
+ zope.location
+ zope.proxy
+ nose
+ coverage
+ nosexcover
+
+[testenv:docs]
+basepython =
+ python2.6
+commands =
+ sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+ sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
+deps =
+ RestrictedPython
+ zope.interface
+ zope.testing
+ zope.configuration
+ zope.component
+ zope.location
+ zope.proxy
+ Sphinx
+ repoze.sphinx.autointerface