summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.rst3
-rw-r--r--setup.py5
2 files changed, 5 insertions, 3 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index b22c091..9a7b503 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,6 +5,9 @@
5.8 (unreleased)
================
+- The extra ``untrustedpython`` now for Python 3, too, installs
+ ``zope.untrustedpython``.
+
5.7 (2022-11-17)
================
diff --git a/setup.py b/setup.py
index 1c82eab..9184288 100644
--- a/setup.py
+++ b/setup.py
@@ -194,10 +194,9 @@ setup(name='zope.security',
'pytz': [
"pytz"
],
- 'untrustedpython:python_version == "2.7"': [
- 'zope.untrustedpython',
+ 'untrustedpython': [
+ 'zope.untrustedpython >= 5.0.dev0',
],
- 'untrustedpython:python_version >= "3.3"': [],
'zcml': [
'zope.configuration'
],