summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2013-03-11 13:11:01 -0400
committerTres Seaver <tseaver@palladion.com>2013-03-11 13:11:01 -0400
commitfcf50572192bcc003e0f42faeffed419f711372c (patch)
tree68fe637e7f86e1a65ffca8439c86f12cc325eb02 /tox.ini
parent928658355be5bec8fa7a722b132a672e9ac6afaa (diff)
downloadzope-security-fcf50572192bcc003e0f42faeffed419f711372c.tar.gz
Add test environments for the PURE_PYTHON environment variable.
Get the one test which failed under that environment to pass.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini14
1 files changed, 13 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index a2df416..c9f597c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py26,py27,pypy,jython,py32,py33,coverage,docs
- py26,py27,pypy,py32,py33,coverage,docs
+ py26,py27,py27-pure,pypy,py32,py33,py33-pure,coverage,docs
[testenv]
deps =
@@ -17,6 +17,18 @@ deps =
commands =
python setup.py test -q
+[testenv:py27-pure]
+basepython =
+ python2.7
+setenv =
+ PURE_PYTHON = 1
+
+[testenv:py33-pure]
+basepython =
+ python3.3
+setenv =
+ PURE_PYTHON = 1
+
[testenv:coverage]
basepython =
python2.6