summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-03-23 21:59:57 -0400
committerTres Seaver <tseaver@palladion.com>2016-03-23 21:59:57 -0400
commitc564507028d71c1ccf186986a261432a9c2dac4c (patch)
treeb68410816f0e9f5ffc528ad40e964cdcf942a6e2
parent1be18cd5ca667f735635ec0225c296b6cbc06b6b (diff)
parent92133dd1aae7eeee83fa50d2fd6a46a1974f27a6 (diff)
downloadzope-security-c564507028d71c1ccf186986a261432a9c2dac4c.tar.gz
Merge pull request #15 from zopefoundation/drop-py26-py32-support
Drop support for Python 2.6 and 3.2.
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst6
-rw-r--r--setup.py4
-rw-r--r--tox.ini8
4 files changed, 9 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 6cd8866..b35a2dd 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,10 +5,8 @@ matrix:
- python: 3.5
env: TOXENV=py35
env:
- - TOXENV=py26
- TOXENV=py27
- TOXENV=py27-pure
- - TOXENV=py32
- TOXENV=py33
- TOXENV=py33-pure
- TOXENV=py34
diff --git a/CHANGES.rst b/CHANGES.rst
index a2de258..c79392f 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,10 +1,12 @@
Changes
=======
-4.0.4 (unreleased)
+4.1.0 (unreleased)
------------------
-- Claim support for Python 3.5.
+- Drop support for Python 2.6 and 3.2.
+
+- Add support for Python 3.5.
4.0.3 (2015-06-02)
------------------
diff --git a/setup.py b/setup.py
index ab5a679..611eea0 100644
--- a/setup.py
+++ b/setup.py
@@ -105,7 +105,7 @@ else:
]
setup(name='zope.security',
- version='4.0.4.dev0',
+ version='4.1.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -122,10 +122,8 @@ setup(name='zope.security',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
diff --git a/tox.ini b/tox.ini
index 6f184d2..c57c86a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,8 +2,8 @@
envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py26,py27,pypy,jython,py32,py33,coverage,docs
- py26,py27,py27-pure,pypy,py32,py33,py33-pure,py34,py35,coverage,docs
+# py27,pypy,jython,py33,coverage,docs
+ py27,py27-pure,pypy,py33,py33-pure,py34,py35,coverage,docs
[testenv]
deps =
@@ -31,13 +31,13 @@ setenv =
[testenv:coverage]
basepython =
- python2.6
+ python2.7
commands =
# The installed version messes up nose's test discovery / coverage reporting
# So, we uninstall that from the environment, and then install the editable
# version, before running nosetests.
pip uninstall -y zope.security
- python -c "import shutil; shutil.copyfile('src/zope/__init__.py', '{envdir}/lib/python2.6/site-packages/zope/__init__.py')"
+ python -c "import shutil; shutil.copyfile('src/zope/__init__.py', '{envdir}/lib/python2.7/site-packages/zope/__init__.py')"
pip install -e .
nosetests --with-xunit --with-xcoverage
deps =