summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2015-11-07 18:37:19 +0200
committerMarius Gedminas <marius@gedmin.as>2015-11-07 18:37:19 +0200
commit1be18cd5ca667f735635ec0225c296b6cbc06b6b (patch)
tree0322c5b8d9657a4fb2ab439460ac1c7cef8ede26
parentb40c7764ce686d972ac0d4a7ada888ed1a9838b9 (diff)
parent127f53ecdb12c418e200ff25e2858ccb4617267c (diff)
downloadzope-security-1be18cd5ca667f735635ec0225c296b6cbc06b6b.tar.gz
Merge pull request #14 from felixonmars/master
Note explicit support for Python 3.5
-rw-r--r--.travis.yml4
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 8 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index df74a27..6cd8866 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,5 +1,9 @@
language: python
sudo: false
+matrix:
+ include:
+ - python: 3.5
+ env: TOXENV=py35
env:
- TOXENV=py26
- TOXENV=py27
diff --git a/CHANGES.rst b/CHANGES.rst
index 268656d..a2de258 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,7 +4,7 @@ Changes
4.0.4 (unreleased)
------------------
-- TBD
+- Claim support for Python 3.5.
4.0.3 (2015-06-02)
------------------
diff --git a/README.rst b/README.rst
index f7569ea..b03d0b7 100644
--- a/README.rst
+++ b/README.rst
@@ -1,7 +1,7 @@
``zope.security``
=================
-.. image:: https://pypip.in/version/zope.security/badge.svg?style=flat
+.. image:: https://img.shields.io/pypi/v/zope.security.svg
:target: https://pypi.python.org/pypi/zope.security/
:alt: Latest Version
diff --git a/setup.py b/setup.py
index 9cf8b18..ab5a679 100644
--- a/setup.py
+++ b/setup.py
@@ -128,6 +128,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index d44a6f4..6f184d2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py26,py27,pypy,jython,py32,py33,coverage,docs
- py26,py27,py27-pure,pypy,py32,py33,py33-pure,py34,coverage,docs
+ py26,py27,py27-pure,pypy,py32,py33,py33-pure,py34,py35,coverage,docs
[testenv]
deps =