summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2013-02-28 11:56:25 -0500
committerStephan Richter <stephan.richter@gmail.com>2013-02-28 11:56:25 -0500
commit962c1635f90a31486b9bfdf33a87ed4b2a780f35 (patch)
treeb41a910f003d50cfa35feaec5b2ad3cb209ad925
parente70fa6c80ae43a43faaf5e9244ab29fb6246c0c4 (diff)
downloadzope-security-962c1635f90a31486b9bfdf33a87ed4b2a780f35.tar.gz
- Remove ``untrustedpython`` extra again, since we do not want to support
``zope.untrustedpython`` in ZTK 2.0. If BBB is really needed, we will create a 3.10.0 release.
-rw-r--r--CHANGES.rst7
-rw-r--r--setup.py1
-rw-r--r--src/zope/security/untrustedpython/__init__.py17
-rw-r--r--src/zope/security/untrustedpython/builtins.py22
-rw-r--r--src/zope/security/untrustedpython/interpreter.py22
-rw-r--r--src/zope/security/untrustedpython/rcompile.py22
6 files changed, 7 insertions, 84 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index f4e81e5..c3a6043 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -13,6 +13,13 @@ CHANGES
- ``z.s._proxy.getObject``
- ``z.s._proxy._Proxy``
+4.0.0a4 (unreleased)
+--------------------
+
+- Remove ``untrustedpython`` extra again, since we do not want to support
+ ``zope.untrustedpython`` in ZTK 2.0. If BBB is really needed, we will create
+ a 3.10.0 release.
+
4.0.0a3 (2013-02-15)
--------------------
diff --git a/setup.py b/setup.py
index 7d538d4..8551417 100644
--- a/setup.py
+++ b/setup.py
@@ -153,7 +153,6 @@ setup(name='zope.security',
test=TESTS_REQUIRE,
testing=TESTS_REQUIRE + ['nose', 'coverage'],
docs=['Sphinx', 'repoze.sphinx.autointerface'],
- untrustedpython=['zope.untrustedpython', 'zope.deprecation'],
),
include_package_data = True,
zip_safe = False,
diff --git a/src/zope/security/untrustedpython/__init__.py b/src/zope/security/untrustedpython/__init__.py
deleted file mode 100644
index 88f81c0..0000000
--- a/src/zope/security/untrustedpython/__init__.py
+++ /dev/null
@@ -1,17 +0,0 @@
-##############################################################################
-#
-# Copyright (c) 2004 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-from warnings import warn
-warn('Import from zope.untrustedpython. This BBB module will'
- 'be removed in zope.security 4.1', DeprecationWarning, 2)
-del warn
diff --git a/src/zope/security/untrustedpython/builtins.py b/src/zope/security/untrustedpython/builtins.py
deleted file mode 100644
index 6975cc7..0000000
--- a/src/zope/security/untrustedpython/builtins.py
+++ /dev/null
@@ -1,22 +0,0 @@
-##############################################################################
-#
-# Copyright (c) 2004 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-from warnings import warn
-warn('Import from zope.untrustedpython.builtins. This BBB module will'
- 'be removed in zope.security 4.1', DeprecationWarning, 2)
-del warn
-
-try:
- from zope.untrustedpython.builtins import *
-except ImportError:
- pass
diff --git a/src/zope/security/untrustedpython/interpreter.py b/src/zope/security/untrustedpython/interpreter.py
deleted file mode 100644
index 5ecc36b..0000000
--- a/src/zope/security/untrustedpython/interpreter.py
+++ /dev/null
@@ -1,22 +0,0 @@
-##############################################################################
-#
-# Copyright (c) 2004 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-from warnings import warn
-warn('Import from zope.untrustedpython.interpreter. This BBB module will'
- 'be removed in zope.security 4.1', DeprecationWarning, 2)
-del warn
-
-try:
- from zope.untrustedpython.interpreter import *
-except ImportError:
- pass
diff --git a/src/zope/security/untrustedpython/rcompile.py b/src/zope/security/untrustedpython/rcompile.py
deleted file mode 100644
index 08eb018..0000000
--- a/src/zope/security/untrustedpython/rcompile.py
+++ /dev/null
@@ -1,22 +0,0 @@
-##############################################################################
-#
-# Copyright (c) 2004 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-from warnings import warn
-warn('Import from zope.untrustedpython.rcompile. This BBB module will'
- 'be removed in zope.security 4.1', DeprecationWarning, 2)
-del warn
-
-try:
- from zope.untrustedpython.rcompile import *
-except ImportError:
- pass