summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2018-08-09 13:56:43 +0300
committerGitHub <noreply@github.com>2018-08-09 13:56:43 +0300
commitbf3a3161675f8ab62796783992d3b3bfba1bbf9d (patch)
tree1350009737b75521beae44db65017d85de37094e
parent50f09de96d97324279821af7fcd32e3bdba06bc7 (diff)
parentc489eb98a1aa9ba31a067d55eb79bea144229e8b (diff)
downloadzope-security-bf3a3161675f8ab62796783992d3b3bfba1bbf9d.tar.gz
Merge pull request #53 from zopefoundation/py37
Add Python 3.7 support
-rw-r--r--.travis.yml3
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--docs/proxy.rst5
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
6 files changed, 12 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 76848c2..75aa4db 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,9 @@ matrix:
- python: 3.4
- python: 3.5
- python: 3.6
+ - python: 3.7
+ dist: xenial
+ sudo: true
- python: pypy
- python: pypy3
- python: 2.7
diff --git a/CHANGES.rst b/CHANGES.rst
index 186a474..3f1f5e7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -13,6 +13,8 @@
``unicode`` is called. See `issue 10
<https://github.com/zopefoundation/zope.security/issues/10>`_.
+- Add support for Python 3.7.
+
4.2.1 (2017-11-30)
==================
diff --git a/appveyor.yml b/appveyor.yml
index 66c2683..ec786c7 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -13,6 +13,8 @@ environment:
- python: 35-x64
- python: 36
- python: 36-x64
+ - python: 37
+ - python: 37-x64
- { python: 27, PURE_PYTHON: 1 }
- { python: 35, PURE_PYTHON: 1 }
diff --git a/docs/proxy.rst b/docs/proxy.rst
index 2b01ee0..5262e7a 100644
--- a/docs/proxy.rst
+++ b/docs/proxy.rst
@@ -343,12 +343,13 @@ In this case, the workarounds described :ref:`above <isinstance-and-proxies>` al
.. pure-python platforms to make sure that we get where
.. we expect to be when we construct LogRecord; otherwise
.. the ProxyMetaclass may be in the negative cache, bypassing
-.. the issubclass() calls we expect
+.. the issubclass() calls we expect.
.. doctest::
:hide:
- >>> ABCMeta._abc_invalidation_counter += 1
+ >>> if hasattr(ABCMeta, '_abc_invalidation_counter'):
+ ... ABCMeta._abc_invalidation_counter += 1
logging
~~~~~~~
diff --git a/setup.py b/setup.py
index 04ec088..f3ce592 100644
--- a/setup.py
+++ b/setup.py
@@ -154,6 +154,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 59a677c..d41b7a3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py27,pypy,jython,py33,coverage,docs
- py27,py27-watch,pypy,pypy3,py34-watch,py34,py35,py36,coverage,docs
+ py27,py27-watch,pypy,pypy3,py34-watch,py34,py35,py36,py37,coverage,docs
[testenv]
commands =