summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-09-11 13:28:29 -0500
committerJason Madden <jamadden@gmail.com>2017-09-11 16:15:47 -0500
commit59edaa22bf0332410dc8d44bec9c6a26b75015f6 (patch)
tree2a3b49b228226324f75dd7a8d6701fb539e72549
parent68661921272216395c07796a8d34914750e7eb68 (diff)
downloadzope-security-59edaa22bf0332410dc8d44bec9c6a26b75015f6.tar.gz
Badges and fixes for README and CHANGES.
-rw-r--r--CHANGES.rst95
-rw-r--r--README.rst23
2 files changed, 63 insertions, 55 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 80d310f..fb06cc5 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,14 +1,15 @@
-Changes
-=======
+=========
+ Changes
+=========
-4.1.2 (unreleased)
-------------------
+4.2.0 (unreleased)
+==================
- Fix the extremely rare potential for a crash when the C extensions
are in use. See `issue 35 <https://github.com/zopefoundation/zope.security/issues/35>`_.
- Fix `issue 7
- <https://github.com/zopefoundation/zope.security/issues/7`_: The
+ <https://github.com/zopefoundation/zope.security/issues/7>`_: The
pure-Python proxy didn't propagate ``TypeError`` from ``__repr__``
and ``__str__`` like the C implementation did.
@@ -48,7 +49,7 @@ Changes
- Remove ``zope.security.setup``. It was unused and did not work anyway.
4.1.1 (2017-05-17)
-------------------
+==================
- Fix `issue 23 <https://github.com/zopefoundation/zope.security/issues/23>`_:
iteration of ``collections.OrderedDict`` and its various views is
@@ -58,7 +59,7 @@ Changes
allowed by default.
4.1.0 (2017-04-24)
-------------------
+==================
- When testing ``PURE_PYTHON`` environments under ``tox``, avoid poisoning
the user's global wheel cache.
@@ -72,13 +73,13 @@ Changes
``BTrees.items()`` on Python 3. The same applies for ``keys()`` and ``values()``.
4.0.3 (2015-06-02)
-------------------
+==================
- Fix iteration over security proxies in Python 3 using the pure-Python
implementation.
4.0.2 (2015-06-02)
-------------------
+==================
- Fix compatibility with ``zope.proxy`` 4.1.5 under PyPy.
@@ -86,12 +87,12 @@ Changes
incorrect results if given a proxy under PyPy.
4.0.1 (2014-03-19)
-------------------
+==================
- Add support for Python 3.4.
4.0.0 (2013-07-09)
-------------------
+==================
- Update ``boostrap.py`` to version 2.2.
@@ -102,7 +103,7 @@ Changes
4.0.0b1 (2013-03-11)
---------------------
+====================
- Add support for PyPy.
@@ -110,26 +111,26 @@ Changes
4.0.0a5 (2013-02-28)
---------------------
+====================
- Undo changes from 4.0.0a4. Instead, ``zope.untrustedpython`` is only
included during Python 2 installs.
4.0.0a4 (2013-02-28)
---------------------
+====================
- Remove ``untrustedpython`` extra again, since we do not want to support
``zope.untrustedpython`` in ZTK 2.0. If BBB is really needed, we will create
a 3.10.0 release.
4.0.0a3 (2013-02-15)
---------------------
+====================
- Fix test breakage in 4.0.0a2 due to deprecation strategy.
4.0.0a2 (2013-02-15)
---------------------
+====================
- Add back the ``untrustedpython`` extra: now pulls in
``zope.untrustedpython``. Restored deprecated backward-compatible imports
@@ -138,7 +139,7 @@ Changes
4.0.0a1 (2013-02-14)
---------------------
+====================
- Add support for Python 3.2 and 3.3.
@@ -189,7 +190,7 @@ Changes
``with interaction()``.
3.9.0 (2012-12-21)
-------------------
+==================
- Pin ``zope.proxy >= 4.1.0``
@@ -197,18 +198,18 @@ Changes
4.1.x version ov ``zope.proxy``.
3.8.5 (2012-12-21)
-------------------
+==================
- Ship with an included ``proxy.h`` header which is compatible with the
supported versions of ``zope.proxy``.
3.8.4 (2012-12-20)
-------------------
+==================
- Pin ``zope.proxy >= 3.4.2, <4.1dev``
3.8.3 (2011-09-24)
-------------------
+==================
- Fix a regression introduced in 3.8.1: ``zope.location``\'s LocationProxy
did not get a security checker if ``zope.security.decorator`` was not
@@ -217,13 +218,13 @@ Changes
3.8.1.
3.8.2 (2011-05-24)
-------------------
+==================
- Fix a test that failed on Python 2.7.
3.8.1 (2011-05-03)
-------------------
+==================
- Fix circular import beween ``zope.security.decorator`` and
``zope.security.proxy`` which led to an ``ImportError`` when only
@@ -231,7 +232,7 @@ Changes
3.8.0 (2010-12-14)
-------------------
+==================
- Add tests for our own ``configure.zcml``.
@@ -243,7 +244,7 @@ Changes
3.7.3 (2010-04-30)
-------------------
+==================
- Prefer the standard library's ``doctest`` module to the one from
``zope.testing``.
@@ -259,13 +260,13 @@ Changes
3.7.2 (2009-11-10)
-------------------
+==================
- Add compatibility with Python 2.6 abstract base classes.
3.7.1 (2009-08-13)
-------------------
+==================
- Fix for LP bug 181833 (from Gustavo Niemeyer). Before "visiting" a
sub-object, a check should be made to ensure the object is still valid.
@@ -277,7 +278,7 @@ Changes
3.7.0 (2009-05-13)
-------------------
+==================
- Make ``pytz`` a soft dependency: the checker for ``pytz.UTC`` is
created / tested only if the package is already present. Run
@@ -285,7 +286,7 @@ Changes
3.6.3 (2009-03-23)
-------------------
+==================
- Ensure that simple zope.schema's ``VocabularyRegistry`` is used for
``PermissionVocabulary`` tests, because it's replaced implicitly in
@@ -299,7 +300,7 @@ Changes
3.6.2 (2009-03-14)
-------------------
+==================
- Add ``zope.i18nmessageid.Message`` to non-proxied basic types. It's okay,
because messages are immutable. Done previously by ``zope.app.security``.
@@ -328,7 +329,7 @@ Changes
3.6.1 (2009-03-10)
-------------------
+==================
- Use ``from`` imports instead of ``zope.deferred`` to avoid circular
import problems, thus drop dependency on ``zope.deferredimport``.
@@ -347,7 +348,7 @@ Changes
3.6.0 (2009-01-31)
-------------------
+==================
- Install decorated security checker support on ``LocationProxy`` from the
outside.
@@ -365,27 +366,27 @@ Changes
3.5.2 (2008-07-27)
-------------------
+==================
- Make C code compatible with Python 2.5 on 64bit architectures.
3.5.1 (2008-06-04)
-------------------
+==================
- Add ``frozenset``, ``set``, ``reversed``, and ``sorted`` to the list of
safe builtins.
3.5.0 (2008-03-05)
-------------------
+==================
- Changed title for ``zope.security.management.system_user`` to be more
presentable.
3.4.3 - (2009/11/26)
---------------------
+====================
- Backport a fix made by Gary Poster to the 3.4 branch:
Fix for LP bug 181833 (from Gustavo Niemeyer). Before "visiting" a
@@ -398,7 +399,7 @@ Changes
3.4.2 - (2009/03/23)
---------------------
+====================
- Add dependency on ``zope.thread`` to setup.py; without it, the tests were
failing.
@@ -411,31 +412,31 @@ Changes
3.4.1 - 2008/07/27
-------------------
+==================
- Make C code compatible with Python 2.5 on 64bit architectures.
3.4.0 (2007-10-02)
-------------------
+==================
- Update meta-data.
3.4.0b5 (2007-08-15)
---------------------
+====================
- Fix a circular import in the C implementation.
3.4.0b4 (2007-08-14)
---------------------
+====================
- Improve ugly/brittle ID of ``zope.security.management.system_user``.
3.4.0b3 (2007-08-14)
---------------------
+====================
- Add support for Python 2.5.
@@ -448,7 +449,7 @@ Changes
3.4.0b2 (2007-06-15)
---------------------
+====================
- Bug: Remove stack extraction in ``newInteraction``. When using eggs this is
an extremly expensive function. The publisher is now more than 10 times
@@ -456,7 +457,7 @@ Changes
3.4.0b1
--------
+=======
- Temporarily fixed the hidden (and accidental) dependency on zope.testing to
become optional.
@@ -466,7 +467,7 @@ individual package and have been documented in the Zope 3 changelog.
3.2.0 (2006-01-05)
-------------------
+==================
- Corresponds to the verison of the ``zope.security`` package shipped as part
of the Zope 3.2.0 release.
@@ -485,7 +486,7 @@ individual package and have been documented in the Zope 3 changelog.
3.1.0 (2005-10-03)
-------------------
+==================
- Add support for use of the new Python 2.4 datatypes, ``set`` and
``frozenset``, within checked code.
@@ -514,7 +515,7 @@ individual package and have been documented in the Zope 3 changelog.
3.0.0 (2004-11-07)
-------------------
+==================
- Corresponds to the version of the ``zope.security`` package shipped as part
of the Zope X3.0.0 release.
diff --git a/README.rst b/README.rst
index 8c04f93..19d5608 100644
--- a/README.rst
+++ b/README.rst
@@ -1,20 +1,27 @@
-``zope.security``
-=================
+===============
+ zope.security
+===============
.. image:: https://img.shields.io/pypi/v/zope.security.svg
- :target: https://pypi.python.org/pypi/zope.security/
- :alt: Latest Version
+ :target: https://pypi.python.org/pypi/zope.security/
+ :alt: Latest release
+
+.. image:: https://img.shields.io/pypi/pyversions/zope.security.svg
+ :target: https://pypi.org/project/zope.security/
+ :alt: Supported Python versions
.. image:: https://travis-ci.org/zopefoundation/zope.security.png?branch=master
:target: https://travis-ci.org/zopefoundation/zope.security
-.. image:: https://readthedocs.org/projects/zopesecurity/badge/?version=latest
- :target: http://zopesecurity.readthedocs.org/en/latest/
- :alt: Documentation Status
-
.. image:: https://coveralls.io/repos/github/zopefoundation/zope.security/badge.svg?branch=master
:target: https://coveralls.io/github/zopefoundation/zope.security?branch=master
+.. image:: https://readthedocs.org/projects/zopesecurity/badge/?version=latest
+ :target: https://zopesecurity.readthedocs.io/en/latest/
+ :alt: Documentation Status
+
The Security framework provides a generic mechanism to implement security
policies on Python objects.
+
+Documentation is available at https://zopesecurity.readthedocs.io/