summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2015-06-01 14:25:00 -0400
committerTres Seaver <tseaver@palladion.com>2015-06-01 14:25:00 -0400
commitbe4c3a69977bd64e3dcf47a5c000592706a6d113 (patch)
treee6d0a2ec60463dc1651c4d94665244ef2adebd7f
parentc3e15d801b0ea46ead0931246b02b8f8d086b9cb (diff)
downloadzope-security-be4c3a69977bd64e3dcf47a5c000592706a6d113.tar.gz
Switch to using 'tox' on Travis.
Add tests for 'py27-pure', 'py33-pure', 'py34', 'coverage', and 'docs' builds.
-rw-r--r--.travis.yml21
1 files changed, 14 insertions, 7 deletions
diff --git a/.travis.yml b/.travis.yml
index cd437ab..df74a27 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,13 +1,20 @@
language: python
sudo: false
-python:
- - 2.6
- - 2.7
- - 3.2
- - 3.3
+env:
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py27-pure
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py33-pure
+ - TOXENV=py34
+ - TOXENV=pypy
+ - TOXENV=pypy3
+ - TOXENV=coverage
+ - TOXENV=docs
install:
- - pip install . --use-mirrors
+ - pip install tox
script:
- - python setup.py test -q
+ - tox
notifications:
email: false