summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-05-02 15:08:39 +0200
committerMichael Howitz <mh@gocept.com>2023-05-02 15:08:39 +0200
commite492ed68d8c8356dff42e97cad6ef096b18fdb5c (patch)
tree0268109ce7e5496e3bf3b002efb839b1b4f94a3c
parent7b95d8cb0cd34251f6072750e0d500e9d09a31c6 (diff)
downloadzope-security-e492ed68d8c8356dff42e97cad6ef096b18fdb5c.tar.gz
Fix docs and coverage environments.
-rw-r--r--setup.py2
-rw-r--r--tox.ini8
2 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 1323fba..70f561b 100644
--- a/setup.py
+++ b/setup.py
@@ -118,7 +118,7 @@ setup(name='zope.security',
'zope.i18nmessageid',
'zope.interface',
'zope.location',
- 'zope.proxy >= 4.1.0',
+ 'zope.proxy >= 4.1.0, < 5',
'zope.schema',
],
test_suite = '__main__.alltests',
diff --git a/tox.ini b/tox.ini
index 7749318..4f7fdb8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -32,14 +32,14 @@ setenv =
[testenv:coverage]
basepython =
- python2.6
+ python2.7
commands =
# The installed version messes up nose's test discovery / coverage reporting
# So, we uninstall that from the environment, and then install the editable
# version, before running nosetests.
pip uninstall -y zope.security
- python -c "import shutil; shutil.copyfile('src/zope/__init__.py', '{envdir}/lib/python2.6/site-packages/zope/__init__.py')"
- pip install -e .
+ python -c "import shutil; shutil.copyfile('src/zope/__init__.py', '{envdir}/lib/python2.7/site-packages/zope/__init__.py')"
+ pip install -e .[test]
nosetests --with-xunit --with-xcoverage
deps =
zope.interface
@@ -54,7 +54,7 @@ deps =
[testenv:docs]
basepython =
- python3.3
+ python3.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest