summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2013-02-15 11:39:20 -0500
committerTres Seaver <tseaver@palladion.com>2013-02-15 11:39:20 -0500
commit010aafbeca43cecba292b7c4a565979002a3faa2 (patch)
tree16b3151f86761a46fed0cea2d2617e3a9ac6cdd7
parentafd7d5841e12fac37289e3d00eb9ac83d2f5a5b6 (diff)
downloadzope-security-010aafbeca43cecba292b7c4a565979002a3faa2.tar.gz
Prep 4.0.0a2 release.4.0.0a2
-rw-r--r--CHANGES.rst14
-rw-r--r--setup.py3
2 files changed, 8 insertions, 9 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 5678dbf..5fd9e86 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,16 +2,14 @@
CHANGES
=======
-4.0.0 (unreleased)
-------------------
-
-- TODO: Add PyPy support
-- TODO: add pure-Python implementations of:
+4.0.0a2 (2013-02-15)
+--------------------
- - ``z.s._proxy.getChecker``
- - ``z.s._proxy.getObject``
- - ``z.s._proxy._Proxy``
+- Added back the ``untrustedpython`` extra: now pulls in
+ ``zope.untrustedpython``. Restored deprecated backward-compatible imports
+ for ``zope.security.untrustedpython.{builtins,interpreter,rcompile}``
+ (the extra and the imports are to be removed in version 4.1).
4.0.0a1 (2013-02-14)
diff --git a/setup.py b/setup.py
index ffca17f..1ac16fe 100644
--- a/setup.py
+++ b/setup.py
@@ -88,7 +88,7 @@ else:
]
setup(name='zope.security',
- version='4.0.0dev',
+ version='4.0.0a2',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -138,6 +138,7 @@ setup(name='zope.security',
test=TESTS_REQUIRE,
testing=TESTS_REQUIRE + ['nose', 'coverage'],
docs=['Sphinx', 'repoze.sphinx.autointerface'],
+ untrustedpython=['zope.untrustedpython', 'zope.deprecation'],
),
include_package_data = True,
zip_safe = False,