summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2013-02-28 13:45:39 -0500
committerStephan Richter <stephan.richter@gmail.com>2013-02-28 13:45:39 -0500
commit15686d565ab33ce52008e8c0375bb34bc4c33464 (patch)
treecb314f799b90c4dd6ef40643b33497618632e404
parent67e98b83aee9bb678b504d37f7f2fbbd2df58018 (diff)
downloadzope-security-15686d565ab33ce52008e8c0375bb34bc4c33464.tar.gz
- Undo changes from 4.0.0a4. Instead, ``zope.untrustedpython`` is only
included during Python 2 installs.
-rw-r--r--CHANGES.rst3
-rw-r--r--buildout.cfg2
-rw-r--r--setup.py2
3 files changed, 5 insertions, 2 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 1c434f5..d9280de 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,8 @@ CHANGES
4.0.0a5 (unreleased)
--------------------
-- Nothing changed yet.
+- Undo changes from 4.0.0a4. Instead, ``zope.untrustedpython`` is only
+ included during Python 2 installs.
4.0.0a4 (2013-02-28)
diff --git a/buildout.cfg b/buildout.cfg
index 5d65d3b..0a7118d 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -14,7 +14,7 @@ eggs =
[python]
recipe = zc.recipe.egg
eggs =
- zope.security
+ zope.security [test,zcml,pytz,untrustedpython]
interpreter = python
[coverage-test]
diff --git a/setup.py b/setup.py
index b9385f6..fa1620c 100644
--- a/setup.py
+++ b/setup.py
@@ -81,6 +81,7 @@ include = [ModuleHeaderDir('zope.proxy')]
# Jython cannot build the C optimizations, while on PyPy they are
# anti-optimizations (the C extension compatibility layer is known-slow,
# and defeats JIT opportunities).
+py3 = sys.version_info[0] >= 3
py_impl = getattr(platform, 'python_implementation', lambda: None)
pure_python = os.environ.get('PURE_PYTHON', False)
is_pypy = py_impl() == 'PyPy'
@@ -149,6 +150,7 @@ setup(name='zope.security',
tests_require=TESTS_REQUIRE,
extras_require = dict(
pytz=["pytz"],
+ untrustedpython=['zope.untrustedpython'] if not py3 else [],
zcml=['zope.configuration'],
test=TESTS_REQUIRE,
testing=TESTS_REQUIRE + ['nose', 'coverage'],