summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-04-14 12:52:13 -0400
committerTres Seaver <tseaver@palladion.com>2016-04-14 12:52:13 -0400
commita77ac68fb510dd1259bfec0a6867d24d8e399997 (patch)
treea1751fabbac81aae8d98528ac5d59b63cfdd3860
parentd5ade943e98cde15d6c07cf32b141ed2372bc15a (diff)
downloadzope-publisher-a77ac68fb510dd1259bfec0a6867d24d8e399997.tar.gz
Add support for Python 3.5.add-py35-support
-rw-r--r--.travis.yml19
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
4 files changed, 12 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 1ec04b0..37c5317 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,15 @@
language: python
sudo: false
-
-env:
- - TOXENV=py27
- - TOXENV=py33
- - TOXENV=py34
- - TOXENV=pypy
- - TOXENV=pypy3
-
+python:
+ - 2.7
+ - 3.3
+ - 3.4
+ - 3.5
+ - pypy
+ - pypy3
install:
- - travis_retry pip install tox
-
+ - pip install tox-travis
script:
- tox
-
notifications:
email: false
diff --git a/CHANGES.rst b/CHANGES.rst
index 5d8d252..706a4ce 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,8 @@ Changes
4.3.0 (unreleased)
------------------
+- Add support for Python 3.5.
+
- Drop support for Python 2.6 and 3.2.
diff --git a/setup.py b/setup.py
index 15d2398..8e919ab 100644
--- a/setup.py
+++ b/setup.py
@@ -63,6 +63,7 @@ setup(name='zope.publisher',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index c2cbf18..35eb891 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@ envlist =
[testenv]
commands =
- python setup.py test -q
+ python setup.py -q test -q
# without explicit deps, setup.py test will download a bunch of eggs into $PWD
deps =
six