summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-27 20:44:14 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-27 20:44:14 -0500
commit1b076e654a458ab48d9dc4865f281a49d2d42a76 (patch)
tree282748ff7fecaa720a5e411661ca9b99dc9e55fc
parentbcaa35fce4c8825294f5a399717c4849ea9b33ca (diff)
downloadzope-publisher-1b076e654a458ab48d9dc4865f281a49d2d42a76.tar.gz
Add support for Python 3.4.
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 6 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 11150b2..0b56d4e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- 2.6
- 2.7
- 3.3
+ - 3.4
install:
- pip install . --use-mirrors
script:
diff --git a/CHANGES.rst b/CHANGES.rst
index abeb063..14d72a1 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,10 +1,10 @@
CHANGES
=======
-4.0.1 (unreleased)
+4.1.0 (unreleased)
------------------
-- TBD
+- Add support for Python 3.4.
4.0.0 (2014-12-22)
------------------
diff --git a/setup.py b/setup.py
index 741da01..7a69963 100644
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,7 @@ sample = zope.publisher.tests.test_paste:SamplePublication
'''
setup(name='zope.publisher',
- version='4.0.1.dev0',
+ version='4.1.0.dev0',
url='http://pypi.python.org/pypi/zope.publisher',
license='ZPL 2.1',
author='Zope Foundation and Contributors',
@@ -63,6 +63,7 @@ setup(name='zope.publisher',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
'Natural Language :: English',
'Operating System :: OS Independent',
diff --git a/tox.ini b/tox.ini
index 8f5f4db..c0229e7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py33
+envlist = py26,py27,py33,py34
[testenv]
commands =