summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2018-08-09 17:30:03 +0300
committerGitHub <noreply@github.com>2018-08-09 17:30:03 +0300
commitece715ad180a5620d238869e45d6cc5f2e1848bd (patch)
tree2983015e0cc55a409b2405e26e9c183e9bfac871
parent27e60b8c5db5e6177d374fd8503a53281ebd7d47 (diff)
parentb79005180ab31a58391c3011dbf68ecaff0df6ff (diff)
downloadzope-proxy-ece715ad180a5620d238869e45d6cc5f2e1848bd.tar.gz
Merge pull request #29 from zopefoundation/py37
Add support for Python 3.7
-rw-r--r--.travis.yml4
-rw-r--r--CHANGES.rst4
-rw-r--r--appveyor.yml2
-rw-r--r--setup.py7
-rw-r--r--tox.ini2
5 files changed, 16 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 64b86b1..d1e7c32 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,6 +11,9 @@ matrix:
include:
- python: "2.7"
env: PURE_PYTHON=1
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip
- pip install -U setuptools
@@ -26,6 +29,7 @@ after_success:
notifications:
email: false
+
cache: pip
before_cache:
- rm -f $HOME/.cache/pip/log/debug.log
diff --git a/CHANGES.rst b/CHANGES.rst
index e0ef7d3..38ca914 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -6,12 +6,16 @@ Changes
- Simplify the internal C handling of attribute names in
``__getattribute__`` and ``__setattr__``.
+
- Make building the C extension optional. We still attempt to build it
on supported platforms, but we allow it to fail in case of a missing
compiler or headers. See `issue 26
<https://github.com/zopefoundation/zope.proxy/issues/26>`_.
+
- Test the PURE_PYTHON environment and PyPy3 on Travis CI.
+- Add support for Python 3.7.
+
4.3.0 (2017-09-13)
------------------
diff --git a/appveyor.yml b/appveyor.yml
index 864baa9..f775534 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -13,6 +13,8 @@ environment:
- python: 35-x64
- python: 36
- python: 36-x64
+ - python: 37
+ - python: 37-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index 95aab9d..0eaf8c5 100644
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,7 @@ from setuptools.command.build_ext import build_ext
from setuptools import setup
from setuptools import Feature
+
class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
@@ -62,6 +63,7 @@ def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
+
Cwrapper = Feature(
"C wrapper",
standard=True,
@@ -104,6 +106,7 @@ setup(name='zope.proxy',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
"Framework :: Zope3",
@@ -113,7 +116,7 @@ setup(name='zope.proxy',
keywords='proxy generic transparent',
packages=['zope', 'zope.proxy'],
package_dir={'': 'src'},
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
cmdclass={
'build_ext': optional_build_ext,
},
@@ -126,7 +129,7 @@ setup(name='zope.proxy',
zip_safe=False,
extras_require={
'test': [
- 'zope.security', # We have a circular dependency for testing
+ 'zope.security', # We have a circular dependency for testing
'zope.testrunner',
],
'docs': [
diff --git a/tox.ini b/tox.ini
index 3dfea08..590c864 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py27-pure,py34,py35,py36,py36-pure,pypy,coverage,docs
+ py27,py27-pure,py34,py35,py36,py36-pure,py37,pypy,coverage,docs
[testenv]
deps =