summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-27 17:44:56 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-27 17:44:56 -0500
commit4b23d631af6b89006d8af002d09b3f9a7a1e1eaa (patch)
tree54ef9e1ca69345793f22d2c685e73ea652d5dc24
parentdad79fb7e2148bb3eb51e46f84f89f3e941058d0 (diff)
downloadzope-pagetemplate-4b23d631af6b89006d8af002d09b3f9a7a1e1eaa.tar.gz
Note blockers for PyPy and PyPy3 support.
-rw-r--r--.travis.yml5
-rw-r--r--setup.py3
-rw-r--r--tox.ini4
3 files changed, 12 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 9e115ea..8b14710 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,6 +5,11 @@ env:
- TOXENV=py27
- TOXENV=py33
- TOXENV=py34
+# PyPy support needs cleanup of doctests, plus some help from zope.security.
+# - TOXENV=pypy
+# PyPy3 support needs release of a fix for:
+# https://bitbucket.org/pypy/pypy/issue/1946)
+# - TOXENV=pypy3
install:
- travis_retry pip install tox
script:
diff --git a/setup.py b/setup.py
index d00d0cb..e157dfd 100644
--- a/setup.py
+++ b/setup.py
@@ -99,6 +99,9 @@ setup(name='zope.pagetemplate',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
+# PyPy support needs cleanup of doctests, plus some help from
+# zope.security.
+# 'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
diff --git a/tox.ini b/tox.ini
index d8d3db1..3e944d9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,9 @@
[tox]
envlist =
+# PyPy support needs cleanup of doctests, plus some help from zope.security.
+# PyPy3 support needs release of a fix for:
+# https://bitbucket.org/pypy/pypy/issue/1946)
+# py26,py27,py33,py34,pypy,pypy3
py26,py27,py33,py34
[testenv]