summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-27 17:36:14 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-27 17:36:14 -0500
commit6457fbfd322912adc2e8a07fd66a682c950a4ef6 (patch)
treee016427104a341f237c8ccae0b20710e6bb1f3d3
parentd9fad6c478f2e571d6d10fe08b7643b44fcd3cea (diff)
downloadzope-pagetemplate-6457fbfd322912adc2e8a07fd66a682c950a4ef6.tar.gz
Nest into Github.
-rw-r--r--CHANGES.rst (renamed from CHANGES.txt)43
-rw-r--r--README.rst (renamed from README.txt)3
-rw-r--r--setup.py7
-rw-r--r--src/zope/pagetemplate/architecture.txt1
-rw-r--r--src/zope/pagetemplate/readme.txt13
5 files changed, 30 insertions, 37 deletions
diff --git a/CHANGES.txt b/CHANGES.rst
index 00317f6..d50f977 100644
--- a/CHANGES.txt
+++ b/CHANGES.rst
@@ -1,17 +1,16 @@
-=======
-CHANGES
+Changes
=======
4.0.5 (unreleased)
------------------
-- Nothing changed yet.
+- TBD
4.0.4 (2013-03-15)
------------------
-- Make sure ``ZopePythonExpr`` and ``PythonExpr`` are separate classes even
+- Ensure that ``ZopePythonExpr`` and ``PythonExpr`` are separate classes even
when ``zope.untrustedpython`` is not available. Fixes a ZCML conflict error
in ``zope.app.pagetemplate``.
@@ -25,13 +24,13 @@ CHANGES
4.0.2 (2013-02-22)
------------------
-- Migrated from ``zope.security.untrustedpython`` to ``zope.untrustedpython``.
+- Migrate from ``zope.security.untrustedpython`` to ``zope.untrustedpython``.
-- Made ``zope.untrustedpython`` an extra dependency. Without it, python
+- Make ``zope.untrustedpython`` an extra dependency. Without it, python
expressions are not protected, even though path expressions are still
security wrapped.
-- Added support for Python 3.3.
+- Add support for Python 3.3.
4.0.1 (2012-01-23)
------------------
@@ -43,24 +42,24 @@ CHANGES
4.0.0 (2012-12-13)
------------------
-- Replaced deprecated ``zope.interface.classProvides`` usage with equivalent
+- Replace deprecated ``zope.interface.classProvides`` usage with equivalent
``zope.interface.provider`` decorator.
-- Replaced deprecated ``zope.interface.implements`` usage with equivalent
+- Replace deprecated ``zope.interface.implements`` usage with equivalent
``zope.interface.implementer`` decorator.
-- Dropped support for Python 2.4 and 2.5.
+- Drop support for Python 2.4 and 2.5.
-- PageTemplate.pt_render() has a new argument, check_macro_expansion,
+- PageTemplate.pt_render() has a new argument, ``check_macro_expansion``,
defaulting to True.
-- PageTemplateTracebackSupplement passes check_macro_expansion=False, to
+- PageTemplateTracebackSupplement passes ``check_macro_expansion=False``, to
avoid LP#732972.
3.6.3 (2011-09-21)
------------------
-- Fixed test assertions to be compatible with zope.tal 3.6.
+- Fix test assertions to be compatible with ``zope.tal`` 3.6.
3.6.2 (2011-09-21)
------------------
@@ -69,45 +68,45 @@ CHANGES
the ``cook`` method is a tuple ``(program, macros)``. This follows
the interface for the TAL parser's ``getCode`` method.
- This fixes a legacy compatibility issue where code would expect an
+ Fixes a legacy compatibility issue where code would expect an
``_v_macros`` volatile attribute which was missing.
3.6.1 (2011-08-23)
------------------
-- Fixed issue with missing default value for ``strictinsert``.
+- Fix issue with missing default value for ``strictinsert``.
3.6.0 (2011-08-20)
------------------
-- Replaced StringIO stream class with a faster list-based implementation.
+- Replace StringIO stream class with a faster list-based implementation.
- Abstract out the template engine and program interfaces and allow
implementation replacement via a utility registration.
-- Removed ancient copyright from test files (LP: #607228)
+- Remove ancient copyright from test files (LP: #607228)
3.5.2 (2010-07-08)
------------------
-- Fixed PTRuntimeError exception messages to be consistent across Python
+- Fix ``PTRuntimeError`` exception messages to be consistent across Python
versions, and compatibile with the output under Python 2.4. (More
readable than the previous output under Python 2.6 as well.)
3.5.1 (2010-04-30)
------------------
-- Removed use of 'zope.testing.doctestunit' in favor of stdlib's doctest.
+- Remove use of ``zope.testing.doctestunit`` in favor of stdlib's doctest.
-- Added dependency on "zope.security [untrustedpython]" because the 'engine'
+- Add dependency on "zope.security [untrustedpython]" because the ``engine``
module uses it.
3.5.0 (2009-05-25)
------------------
-- Added test coverage reporting support.
+- Add test coverage reporting support.
-- Moved 'engine' module and related test scaffolding here from
+- Move 'engine' module and related test scaffolding here from
``zope.app.pagetemplate`` package.
3.4.2 (2009-03-17)
diff --git a/README.txt b/README.rst
index 294bf87..f8eb0b3 100644
--- a/README.txt
+++ b/README.rst
@@ -1,3 +1,6 @@
+``zope.pagetemplate``
+=====================
+
Page Templates provide an elegant templating mechanism that achieves a
clean separation of presentation and application logic while allowing
for designers to work with templates in their visual editing tools
diff --git a/setup.py b/setup.py
index 6b6bab1..5d6cae0 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,8 @@ PY3 = sys.version_info[0] >= 3
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
+ return f.read()
def _modname(path, base, name=''):
if path == base:
@@ -74,7 +75,7 @@ setup(name='zope.pagetemplate',
author_email='zope-dev@zope.org',
description='Zope Page Templates',
long_description=(
- read('README.txt')
+ read('README.rst')
+ '\n\n' +
'Detailed Documentation\n' +
'----------------------'
@@ -83,7 +84,7 @@ setup(name='zope.pagetemplate',
+ '\n\n' +
read('src', 'zope', 'pagetemplate', 'readme.txt')
+ '\n\n' +
- read('CHANGES.txt')),
+ read('CHANGES.rst')),
keywords="zope3 page template",
classifiers=[
'Development Status :: 5 - Production/Stable',
diff --git a/src/zope/pagetemplate/architecture.txt b/src/zope/pagetemplate/architecture.txt
index 637b028..2d07ca4 100644
--- a/src/zope/pagetemplate/architecture.txt
+++ b/src/zope/pagetemplate/architecture.txt
@@ -1,4 +1,3 @@
-=====================================
ZPT (Zope Page-Template) Architecture
=====================================
diff --git a/src/zope/pagetemplate/readme.txt b/src/zope/pagetemplate/readme.txt
index 39c02f1..85f6fda 100644
--- a/src/zope/pagetemplate/readme.txt
+++ b/src/zope/pagetemplate/readme.txt
@@ -1,14 +1,5 @@
-==============
-Page Templates
-==============
-
-Introduction
-------------
-
-Page Templates provide an elegant templating mechanism that achieves a
-clean separation of presentation and application logic while allowing
-for designers to work with templates in their visual editing tools
-(FrontPage, Dreamweaver, GoLive, etc.).
+ZPT Usage
+=========
This document focuses on usage of Page Templates outside of a Zope
context, it does *not* explain how to write page templates as there