summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2007-10-03 03:18:27 +0000
committerStephan Richter <stephan.richter@gmail.com>2007-10-03 03:18:27 +0000
commit022a2ff699d17863f725bff32beb2b1083e909ae (patch)
treee1bf7efd483f1ee73bccc03702cc3e0b1bea460b
parent1c0ecfee6e3ac6d76f395bec3eb47a58bce9310c (diff)
downloadzope-pagetemplate-022a2ff699d17863f725bff32beb2b1083e909ae.tar.gz
Updated meta-data and get ready for the release.
-rw-r--r--CHANGES.txt49
-rw-r--r--README.txt4
-rw-r--r--buildout.cfg3
-rw-r--r--setup.cfg2
-rw-r--r--setup.py44
5 files changed, 67 insertions, 35 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index baec9d4..98e446e 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,34 +1,41 @@
-zope.pagetemplate Package Changelog
-===================================
+=======
+CHANGES
+=======
-zope.pagetemplate version 3.2.0 (2006/01/05)
---------------------------------------------
+3.4.0 (2007-10-02)
+------------------
-Corresponds to the verison of the zope.pagetemplate package shipped
-as part of the Zope 3.2.0 release.
+- Initial release independent of the Zope 3 tree.
-ZPTPage macro expansion: changed label text to match the corresponding
-label in Zope 2 and activated the name spaces for macro expansion
-in 'read'. See http://www.zope.org/Collectors/Zope3-dev/199
-Coding style cleanups.
+3.2.0 (2006-01-05)
+------------------
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope 3.2.0 release.
-zope.pagetemplate version 3.1.0 (2005/10/03)
---------------------------------------------
+- ZPTPage macro expansion: changed label text to match the corresponding
+ label in Zope 2 and activated the name spaces for macro expansion
+ in 'read'. See http://www.zope.org/Collectors/Zope3-dev/199
-Corresponds to the verison of the zope.pagetemplate package shipped
-as part of the Zope 3.1.0 release.
+- Coding style cleanups.
-Fixed apidoc and Cookie, which were using wrong descriptor class
-(changed to 'property'). See http://www.zope.org/Collectors/Zope3-dev/387
-Documentation / style / testing cleanups.
+3.1.0 (2005-10-03)
+------------------
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope 3.1.0 release.
-zope.pagetemplate version 3.0.0 (2004/11/07)
---------------------------------------------
+- Fixed apidoc and Cookie, which were using wrong descriptor class
+ (changed to 'property'). See http://www.zope.org/Collectors/Zope3-dev/387
-Corresponds to the verison of the zope.pagetemplate package shipped
-as part of the Zope X3.0.0 release.
+- Documentation / style / testing cleanups.
+
+
+3.0.0 (2004-11-07)
+------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope X3.0.0 release.
diff --git a/README.txt b/README.txt
new file mode 100644
index 0000000..294bf87
--- /dev/null
+++ b/README.txt
@@ -0,0 +1,4 @@
+Page Templates provide an elegant templating mechanism that achieves a
+clean separation of presentation and application logic while allowing
+for designers to work with templates in their visual editing tools
+(FrontPage, Dreamweaver, GoLive, etc.).
diff --git a/buildout.cfg b/buildout.cfg
index e1116f5..c35d84b 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -1,8 +1,7 @@
[buildout]
develop = .
parts = test
-find-links = http://download.zope.org/distribution/
[test]
recipe = zc.recipe.testrunner
-eggs = zope.pagetemplate
+eggs = zope.pagetemplate [test]
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 9350078..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[egg_info]
-tag_svn_revision = 1 \ No newline at end of file
diff --git a/setup.py b/setup.py
index 9156ef8..0d6bbe1 100644
--- a/setup.py
+++ b/setup.py
@@ -15,29 +15,53 @@
$Id$
"""
-
import os
-
from setuptools import setup, find_packages
+def read(*rnames):
+ return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+
setup(name='zope.pagetemplate',
- version = '3.4.0b1',
- url='http://svn.zope.org/zope.pagetemplate',
- license='ZPL 2.1',
- description='Zope Page Templates',
+ version = '3.4.0',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
-
+ description='Zope Page Templates',
+ long_description=(
+ read('README.txt')
+ + '\n\n' +
+ 'Detailed Documentation' +
+ '----------------------'
+ + '\n\n' +
+ read('src', 'zope', 'pagetemplate', 'architecture.txt')
+ + '\n\n' +
+ read('src', 'zope', 'pagetemplate', 'readme.txt')
+ + '\n\n' +
+ read('CHANGES.txt')
+ ),
+ keywords = "zope3 page template",
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Zope Public License',
+ 'Programming Language :: Python',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Framework :: Zope3'],
+ url='http://cheeseshop.python.org/pypi/zope.pagetemplate',
+ license='ZPL 2.1',
packages=find_packages('src'),
package_dir = {'': 'src'},
-
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
+ extras_require = dict(
+ test=['zope.testing',
+ ]),
install_requires=['setuptools',
'zope.interface',
'zope.tales',
'zope.tal',
],
include_package_data = True,
-
zip_safe = False,
)