summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jason+github@nextthought.com>2017-01-18 10:33:35 -0600
committerGitHub <noreply@github.com>2017-01-18 10:33:35 -0600
commitb8a36f1b6aa2c4d4470c08b84bb6f5031e33ab30 (patch)
tree41a6aae8e6a2d43d1e80b9a56380fae12b0b5ee4
parent81a3b4e381fa3d5d55579e9719f2751c995041b0 (diff)
downloadzope-interface-b8a36f1b6aa2c4d4470c08b84bb6f5031e33ab30.tar.gz
Add support for Python 3.6. (#74)
* Add support for Python 3.6. Also use macpython for all the mac builds. See zopefoundation/persistent#59 * Install the test extra with pip. hopefully this avoids the SSL issue seen in macpython 3.6 (https://travis-ci.org/zopefoundation/zope.interface/jobs/192367647) Also update appveyor.yml
-rw-r--r--.travis.yml14
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 17 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 34ccc93..f9683ff 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,25 +11,33 @@ matrix:
- os: linux
python: 3.5
- os: linux
+ python: 3.6
+ - os: linux
python: pypy
- os: linux
python: pypy3
+ # It's important to use 'macpython' builds to get the least
+ # restrictive wheel tag. It's also important to avoid
+ # 'homebrew 3' because it floats instead of being a specific version.
- os: osx
language: generic
- env: TERRYFY_PYTHON='homebrew 2'
+ env: TERRYFY_PYTHON='macpython 2.7'
- os: osx
language: generic
env: TERRYFY_PYTHON='macpython 3.4'
- os: osx
language: generic
- env: TERRYFY_PYTHON='homebrew 3'
+ env: TERRYFY_PYTHON='macpython 3.5'
+ - os: osx
+ language: generic
+ env: TERRYFY_PYTHON='macpython 3.6.0'
before_install:
- if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then git clone https://github.com/MacPython/terryfy; fi
- if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then source terryfy/travis_tools.sh; fi
- if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then get_python_environment $TERRYFY_PYTHON venv; fi
- if [[ "$TERRYFY_PYTHON" == "homebrew 3" ]]; then alias pip=`which pip3` ; fi
install:
- - pip install -e .
+ - pip install -e .[test]
script:
- python setup.py test -q
notifications:
diff --git a/CHANGES.rst b/CHANGES.rst
index 0899056..f938cff 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -7,6 +7,8 @@ Changes
- Avoid a warning from the C compiler.
(https://github.com/zopefoundation/zope.interface/issues/71)
+- Add support for Python 3.6.
+
4.3.3 (2016-12-13)
------------------
diff --git a/appveyor.yml b/appveyor.yml
index 505ae3c..0425cc2 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -13,6 +13,8 @@ environment:
- python: 34-x64
- python: 35
- python: 35-x64
+ - python: 36
+ - python: 36-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index 9dbce93..a744372 100644
--- a/setup.py
+++ b/setup.py
@@ -116,6 +116,7 @@ setup(name='zope.interface',
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Framework :: Zope3",
diff --git a/tox.ini b/tox.ini
index 329acd8..9394f2b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py27-pure,py33,py34,py34-pure,py35,pypy,pypy3,coverage,docs
+ py27,py27-pure,py33,py34,py34-pure,py35,py36,pypy,pypy3,coverage,docs
[testenv]
commands =