summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2017-01-12 09:53:38 +0200
committerMarius Gedminas <marius@gedmin.as>2017-01-12 09:54:42 +0200
commit81a3b4e381fa3d5d55579e9719f2751c995041b0 (patch)
tree84f143d0ac9c88f18250a193d76387d78283592e
parentd3fe8d8b9941e2b9b56e7c87bb3b20e435a2627f (diff)
downloadzope-interface-81a3b4e381fa3d5d55579e9719f2751c995041b0.tar.gz
Always build wheels and archive them as artifacts
-rw-r--r--appveyor.yml45
1 files changed, 21 insertions, 24 deletions
diff --git a/appveyor.yml b/appveyor.yml
index adedb91..505ae3c 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,39 +1,36 @@
environment:
- password:
- secure: UcdTh6W78cRLVGfKRFoa5A==
+ global:
+ TWINE_USERNAME: zope.wheelbuilder
+ TWINE_PASSWORD:
+ secure: UcdTh6W78cRLVGfKRFoa5A==
+
matrix:
- - python : 27
- - python : 27-x64
- - python : 33
- - python : 33-x64
- - python : 34
- - python : 34-x64
- - python : 35
- - python : 35-x64
+ - python: 27
+ - python: 27-x64
+ - python: 33
+ - python: 33-x64
+ - python: 34
+ - python: 34-x64
+ - python: 35
+ - python: 35-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
- echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
- pip install -e .
-build: false
+build_script:
+ - pip install wheel
+ - python -W ignore setup.py -q bdist_wheel
test_script:
- python setup.py test -q
-on_success:
- - echo Build succesful!
+artifacts:
+ - path: 'dist\*.whl'
+ name: wheel
deploy_script:
- - echo [distutils] > %USERPROFILE%\\.pypirc
- - echo index-servers = >> %USERPROFILE%\\.pypirc
- - echo pypi >> %USERPROFILE%\\.pypirc
- - echo [pypi] >> %USERPROFILE%\\.pypirc
- - echo repository=https://pypi.python.org/pypi >> %USERPROFILE%\\.pypirc
- - echo username=zope.wheelbuilder >> %USERPROFILE%\\.pypirc
- - echo password=%password% >> %USERPROFILE%\\.pypirc
- - set HOME=%USERPROFILE%
- - pip install wheel twine
- - ps: if($env:APPVEYOR_REPO_TAG -eq $TRUE) { python -W ignore setup.py bdist_wheel; twine upload dist/* }
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload dist/* }
-deploy : on
+deploy: on