summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-02-10 08:56:08 -0600
committerJason Madden <jamadden@gmail.com>2020-02-10 08:56:13 -0600
commitf3622eb8d750801d0169509fe5d34d9675919844 (patch)
tree11765537dd9de5d02e7481f49e0d481c2e279682
parente53e797787f645b20c5598fe9ffab81134309ed3 (diff)
downloadzope-interface-f3622eb8d750801d0169509fe5d34d9675919844.tar.gz
Attempt workaround for virtualenv 20.0 failures.
See https://github.com/zopefoundation/zope.interface/pull/174#issuecomment-584154877
-rw-r--r--.travis.yml13
1 files changed, 9 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index dd4c3e0..2b22998 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -82,13 +82,18 @@ before_install:
fi
install:
- - pip install -U pip setuptools
- - pip install -U coveralls coverage
- - pip install -U -e ".[test]"
+ # virtualenv 20.0 together with terryfy macOS is broken, at least
+ # with CPython 2.7.17:
+ # it doesn't install or activate the virtualenv correctly and PATH
+ # isn't setup right. So try to use `python -m` to workaround that.
+ - python -m pip install -U pip setuptools
+ - python -m pip install -U coveralls coverage
+ - python -m pip install -U -e ".[test]"
script:
+ - which python
- python --version
- - coverage run -m unittest discover -s src
+ - python -m coverage run -m unittest discover -s src
- python setup.py -q bdist_wheel
after_success: