summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jason+github@nextthought.com>2017-06-09 14:34:20 -0500
committerGitHub <noreply@github.com>2017-06-09 14:34:20 -0500
commite6b6ba2181e2265fa814a34a119531b1ddca23bf (patch)
tree9bb452bc70e1bd87977e12110bd5bbd79926095c
parent8bcfddcfbe8a597c7af0de191d51569fa1b1f603 (diff)
downloadzope-interface-e6b6ba2181e2265fa814a34a119531b1ddca23bf.tar.gz
Enable coveralls (#89)
* Enable coveralls Test coverage is not at 100% yet so it should fail this PR. Also enable pip caching since we are installing more deps. Update PyPy versions to latest available for speed and because the old version of PyPy3 can't install newer pip and coverage, etc. Partially addresses #87 * Even newer pypys * Despite the list, pypy-5.6 doesn,t work, it must be 5.6.0
-rw-r--r--.travis.yml16
1 files changed, 12 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index dbc7a79..736f1e7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,9 +13,9 @@ matrix:
- os: linux
python: 3.6
- os: linux
- python: pypy
+ python: pypy-5.6.0
- os: linux
- python: pypy3
+ python: pypy3.3-5.5-alpha
# It's important to use 'macpython' builds to get the least
# restrictive wheel tag. It's also important to avoid
# 'homebrew 3' because it floats instead of being a specific version.
@@ -50,12 +50,15 @@ before_install:
- if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then source terryfy/travis_tools.sh; fi
- if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then get_python_environment $TERRYFY_PYTHON venv; fi
install:
- - pip install -e .[test]
+ - pip install -U pip setuptools
+ - pip install -U coveralls coverage
+ - pip install -U -e ".[test]"
script:
- - python setup.py test -q
+ - coverage run setup.py test -q
notifications:
email: false
after_success:
+ - coveralls
- echo [distutils] > ~/.pypirc
- echo index-servers = pypi >> ~/.pypirc
- echo [pypi] >> ~/.pypirc
@@ -69,3 +72,8 @@ after_success:
env:
global:
secure: "CeOq8/6F8IlbRpKEk2z3RPD/q5cBCPXGOUgjYryG/c+7P6SCTxaTKfxiJPqT3sGgO8x/HcJVuvZghyqCPvysk3cbnq4SiMtI1S0hS/N3DFsGZHn25YQBipAYjA4YDUb6GqCpsSUIXdbGMEzG7DOSB6c+49+//wkjbBFHmPNWvMQ="
+
+cache: pip
+
+before_cache:
+ - rm -f $HOME/.cache/pip/log/debug.log