summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.rst2
-rw-r--r--docs/narr.rst3
-rw-r--r--setup.py2
3 files changed, 3 insertions, 4 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index c9ffa2b..bf6c5dc 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
6.0.1 (unreleased)
==================
-- Nothing changed yet.
+- Drop dependency on ``six``.
6.0.0 (2023-03-23)
diff --git a/docs/narr.rst b/docs/narr.rst
index c844068..1e79298 100644
--- a/docs/narr.rst
+++ b/docs/narr.rst
@@ -74,10 +74,9 @@ Messages at first seem like they are text strings:
.. doctest::
- >>> import six
>>> robot == 'robot-message'
True
- >>> isinstance(robot, six.text_type)
+ >>> isinstance(robot, str)
True
The additional domain, default and mapping information is available
diff --git a/setup.py b/setup.py
index cfb67aa..1873e8b 100644
--- a/setup.py
+++ b/setup.py
@@ -129,7 +129,7 @@ setup(
packages=find_packages('src'),
package_dir={'': 'src'},
namespace_packages=['zope'],
- install_requires=['setuptools', 'six'],
+ install_requires=['setuptools'],
python_requires='>=3.7',
include_package_data=True,
test_suite='zope.i18nmessageid.tests.test_suite',